2008 Explorer Unusual AC / Air Conditioning issue | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

2008 Explorer Unusual AC / Air Conditioning issue

S1L1K0N

Member
Joined
September 29, 2007
Messages
29
Reaction score
0
City, State
Winnipeg, MB, Canada
Year, Model & Trim Level
2008 Explorer V6 XLT
I have a 2008 Explorer XLT with the manual/single zone heating/air conditioning system. I am experiencing an unusual issue with the air conditioning system. When AC is selected (normal or Max) only the passenger side vents blow cold air. From right to left, if you're sitting in the vehicle, the dash passenger side vent closest to the window blows cold, the dash passenger side of the middle vent cluster blows cold(ish), yet the vent right next to it (closest to driver on middle cluster) blows mostly ambient and the drivers side vent closest to the drivers side window blows ambient. AC system seems fully charged as if I put a pressure gauge on the low side port once the compressor comes on it stays on and the pressure stays right between 25-30 psi. I've checked the vacuum lines too and they seem to be in good shape as well. I'm not sure if it's related, but I don't get any cold air out of the rear/roof vents either, yet the heat works fine. Any ideas where to start are greatly appreciated, thanks.
 




Top