2009 Explorer LTD w/4.6L & AWD - Purchased it Now!! New to us | Page 2 | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

2009 Explorer LTD w/4.6L & AWD - Purchased it Now!! New to us

What do the fix ones look like. What a lot of pickups have. Tube chrome types. I doubt he'd want them either we can get in with a step even though it looks high. Brake cables exposed on the driver side is the only negative. Summer job doing something maybe.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





It was a bit of a surprise that there is not built in AC power inverter nor a 12V socket in the storage area on a LTD. One would have to run the cord to the 12V at the 2nd row console. I have both in my Sante Fe AWD which is 2008. Fords approach to the NAV update is totally unreasonable especially consider the cost for it. Double Ouch...

If I find an older DVD its worth seeing if it will work or not. But its another 2 years before some major highway construction is completed.
 






Just washed today. Better now. Eh...

20170208_143535.jpg
 






Our winter sucks. 10C and rising, no snow for snowmobiling if somewhere it will be slush. Anyway, my son is tuninig his ride with a good wash & wax. LOL
What else is one to do short of pretending its spring and on the deck with a cold one. Eh !!!


20170218_114846_resized.jpg
 






First detail, when the weather is 7c(44f) what else are you going to do. Not my best work and all done by hand but not ideal conditions. I'll be look for a dual action polisher for the spring and summer. A LOT of scratches, swirls, chips, gouges etc. Will be quite the operation learning how to improve the close up look.



 






Here is my 2010 with stock, non retracting, running boards. When I was shopping around for this truck, a lot of them had those electric running boards and agree they are a disaster, especially in snow country. These are an 'open style' that will not trap all the snow, water and salt and have it sit there. I just got lucky that this truck did not have them else they would be off by now...

Step.JPG
 






I started a separate thread on this.

Thanks

Who makes that one if you recall? A lower angle picture would help.
 






did not see that...
they are OEM from the Factory... i'll post some pics over on the other thread...
 






Did you get any maintenance records from the previous owner? Sometimes a dealer will keep those docs in the car somewhere or they will clean out everything.
Beautiful new ride. Looks awesome. Good mileage for the year built!! Are the tires in good shape?
 






Carproof showed lots of regular and very often service visits but did not indicate what on the supplied carproof report. Yeah tires are in very good shape.
 






Tripplec and Traiblazer -

do you have identical cars and both with no running boards ?

That's funny....
 












Tripplec and Traiblazer -

do you have identical cars and both with no running boards ?

That's funny....
LOL Well saying Dad would be clearer!! Consultant on it. LOL

Looked into PCV for it when I picked up a Motocraft air filter (existing was black at one end). Dealer said only a hose part of the rocker cover. While manual mentions PCV should be changed but did not list the part number in the table with other other items being filters. Hmmm
 






Back
Top