• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

2013 Blinker...am I the only one??


4sfactot

New Member
Joined
September 15, 2013
Messages
1
Reaction score
0
Year, Model & Trim Level
2013 Explorer
Anyone having this issue needs to go to the dealership. I am in the process of being refunded by my dealer. After asking them multiple times what was wrong, I found the post on how to fix it here, I bought one to fix rather then messing up the current one. Well, unbeknownst to me the new one doesn't have this problem. You can tell the product has been updated as some of the internal plastic had changed colors and it's now smooth as silk to use. When my wife tested it,I had to stop her from pushing because she didn't realize she already put it the whole way down. I noticed the number on the sticker was slightly different to. The one I got was manufactured on 8/2/13. Seems like another issue ford fixed without telling anyone. Thus was purchased from fordparts.com so it was right from their warehouse too. I will post pictures when I get them off my phone tonight. The dealership didn't believe me until I changed it in front of them, literally. The GM was not happy with hs service manager that day.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
27,077
Reaction score
1,490
City, State
Ottawa, Ontario area
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Anyone having this issue needs to go to the dealership. I am in the process of being refunded by my dealer. After asking them multiple times what was wrong, I found the post on how to fix it here, I bought one to fix rather then messing up the current one. Well, unbeknownst to me the new one doesn't have this problem. You can tell the product has been updated as some of the internal plastic had changed colors and it's now smooth as silk to use. When my wife tested it,I had to stop her from pushing because she didn't realize she already put it the whole way down. I noticed the number on the sticker was slightly different to. The one I got was manufactured on 8/2/13. Seems like another issue ford fixed without telling anyone. Thus was purchased from fordparts.com so it was right from their warehouse too. I will post pictures when I get them off my phone tonight. The dealership didn't believe me until I changed it in front of them, literally. The GM was not happy with hs service manager that day.
Welcome to the Forum 4sfactot.:wavey:
Glad you were able to get this resolved. As maliboo74 posted, the dealer should take care of this issue for anyone that has it. For anyone looking to get it changed, it might be an idea to print a copy of that post and take it with you to the dealer. Don't know what they did in the 2013 model to introduce this issue. It appeared to be fine in all previous model years. Don't forget to charge them for your labour as well as the part. ;):thumbsup:

Peter
 




On The Bcyde

New Member
Joined
November 1, 2012
Messages
9
Reaction score
0
City, State
New York
Year, Model & Trim Level
2011 Ford Explorer XLT
Never

I don't think I've ever hit the high beams while hitting the blinkers but I do agree the half blinks should be longer depending on situation or driving style. I just fully engage blinkers if I can't make a move right away
 




13Sport

Well-Known Member
Joined
June 29, 2012
Messages
1,128
Reaction score
4
City, State
Los Angeles, CA
Year, Model & Trim Level
2015 Explorer Sport
I don't think I've ever hit the high beams while hitting the blinkers but I do agree the half blinks should be longer depending on situation or driving style. I just fully engage blinkers if I can't make a move right away
You don't hit your high beams because you are in a 2011.. This problem affects 2013's (and maybe late 2012's)
 




poppylove2013

New Member
Joined
January 28, 2014
Messages
2
Reaction score
0
Year, Model & Trim Level
2013 Explorer Limited
I am new to this forum and a new owner of a previously loved 2013 Ford Explorer. I have been having issues with "flashing" my brights intermittently while using my right turn signal. I've even had a police officer pull me over stating that he thought I was trying to signal to him that I was in distress. My car has 23k and is currently sitting at my local dealership. They cannot replicate the issue, nor can they find anything from Ford indicating this is an issue. So, for now, I have no resolution to the issue. I have sent the customer service rep. a PM with my info and forwarded the service department's foreman to this thread. Does anyone have any further advice?
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
27,077
Reaction score
1,490
City, State
Ottawa, Ontario area
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
I am new to this forum and a new owner of a previously loved 2013 Ford Explorer. I have been having issues with "flashing" my brights intermittently while using my right turn signal. I've even had a police officer pull me over stating that he thought I was trying to signal to him that I was in distress. My car has 23k and is currently sitting at my local dealership. They cannot replicate the issue, nor can they find anything from Ford indicating this is an issue. So, for now, I have no resolution to the issue. I have sent the customer service rep. a PM with my info and forwarded the service department's foreman to this thread. Does anyone have any further advice?
It is all in the way that you put use the lever. You don't want to put any kind of 'lift' pressure on it. In almost 3 years of driving my Explorer I have yet to run into this issue. It doesn't seem to be much of a problem. I think it is just a matter of getting used to the way it operates, which I don't particularly like.

Peter
 




13Sport

Well-Known Member
Joined
June 29, 2012
Messages
1,128
Reaction score
4
City, State
Los Angeles, CA
Year, Model & Trim Level
2015 Explorer Sport
I am new to this forum and a new owner of a previously loved 2013 Ford Explorer. I have been having issues with "flashing" my brights intermittently while using my right turn signal. I've even had a police officer pull me over stating that he thought I was trying to signal to him that I was in distress. My car has 23k and is currently sitting at my local dealership. They cannot replicate the issue, nor can they find anything from Ford indicating this is an issue. So, for now, I have no resolution to the issue. I have sent the customer service rep. a PM with my info and forwarded the service department's foreman to this thread. Does anyone have any further advice?
I complained of the same issue, I explained to my service manager that this problem was being fixed by Ford, that numerous here have had it fixed. He contacted Ford who directed him to replace the indicator lever (multifunction switch). The new one is smooth like butter. PM Crystal (FordService) and have her get this done for you. It's a safety hazard, I explained it to the service manager as I've already been involved in a couple of road rage scenarios due to accidental flashing of oncoming traffic.

It's definitely a safety hazard, if they still refuse to do anything about it, threatening legal action usually will persuade them.
 




13Sport

Well-Known Member
Joined
June 29, 2012
Messages
1,128
Reaction score
4
City, State
Los Angeles, CA
Year, Model & Trim Level
2015 Explorer Sport
It is all in the way that you put use the lever. You don't want to put any kind of 'lift' pressure on it. In almost 3 years of driving my Explorer I have yet to run into this issue. It doesn't seem to be much of a problem. I think it is just a matter of getting used to the way it operates, which I don't particularly like.

Peter
Peter, the 2013 has an issue w/ binding on the lever from the factory. It's very stiff/notchy going into the second position. My 2011 didn't experience this problem, but my 2013 Sport caused many accidental flashes of oncoming traffic.
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
27,077
Reaction score
1,490
City, State
Ottawa, Ontario area
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Peter, the 2013 has an issue w/ binding on the lever from the factory. It's very stiff/notchy going into the second position. My 2011 didn't experience this problem, but my 2013 Sport caused many accidental flashes of oncoming traffic.
Yes, I'm aware of that but the poster didn't say anything about the lever being hard to use since he didn't mention having an issue with a left turn. I therefore thought it was one that didn't have that particular issue.

Peter
 
Last edited:




FordService

Official Ford Rep
Joined
October 25, 2010
Messages
5,281
Reaction score
11
City, State
Dearborn, MI
Year, Model & Trim Level
2014
...I have sent the customer service rep. a PM with my info and forwarded the service department's foreman to this thread...
I got your PM and responded, poppylove2013; let me know if you have any other questions or concerns. :thumbsup:

Crystal
 




poppylove2013

New Member
Joined
January 28, 2014
Messages
2
Reaction score
0
Year, Model & Trim Level
2013 Explorer Limited
I met with the service manager today to drive around and "replicate" the problem. Of course it only happened once & he insisted it was my technique. (I've been driving for well over 20 years, w/o this problem). So no resolution until the service department can replicate themselves. I'm unhappy with that "resolution" as it's clearly an issue. Just switch it out with a 2012 switch & call it good. Incidentally, my husband drives a 2012 F350 with the same mechanism and we've NEVER had an issue.
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
27,077
Reaction score
1,490
City, State
Ottawa, Ontario area
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
I met with the service manager today to drive around and "replicate" the problem. Of course it only happened once & he insisted it was my technique. (I've been driving for well over 20 years, w/o this problem). So no resolution until the service department can replicate themselves. I'm unhappy with that "resolution" as it's clearly an issue. Just switch it out with a 2012 switch & call it good. Incidentally, my husband drives a 2012 F350 with the same mechanism and we've NEVER had an issue.
I'm afraid I tend to agree with the service manager that it is the 'technique'. I've been driving over 50 years and this is the first time I've had this type of signaling system. As I've posted several times, I don't like it.

Peter
 




13Sport

Well-Known Member
Joined
June 29, 2012
Messages
1,128
Reaction score
4
City, State
Los Angeles, CA
Year, Model & Trim Level
2015 Explorer Sport
I'm afraid I tend to agree with the service manager that it is the 'technique'. I've been driving over 50 years and this is the first time I've had this type of signaling system. As I've posted several times, I don't like it.

Peter
This just isn't true. The 2013 switch binds significantly causing the described issue. If some of us have had it replaced and the issue is resolved how can it be considered a driving technique problem.

You don't drive an affected vehicle, so you can't really make that judgement in regard to the posters technique. They said it did happen once during the test drive, that should be enough to apply the known fix.

I would go to another dealer, flashing brights accidentally is a major safety hazard
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
27,077
Reaction score
1,490
City, State
Ottawa, Ontario area
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
This just isn't true. The 2013 switch binds significantly causing the described issue. If some of us have had it replaced and the issue is resolved how can it be considered a driving technique problem.

You don't drive an affected vehicle, so you can't really make that judgement in regard to the posters technique. They said it did happen once during the test drive, that should be enough to apply the known fix.

I would go to another dealer, flashing brights accidentally is a major safety hazard
As I have said before the poster has not mentioned anything about a binding or 'notchy' lever. Not all 2013 models had the issue anyway so you are also possibly jumping to an incorrect conclusion. Given the current info supplied by the poster, I stand by my statement that it is like the technique being used.

Peter
 




13Sport

Well-Known Member
Joined
June 29, 2012
Messages
1,128
Reaction score
4
City, State
Los Angeles, CA
Year, Model & Trim Level
2015 Explorer Sport
As I have said before the poster has not mentioned anything about a binding or 'notchy' lever. Not all 2013 models had the issue anyway so you are also possibly jumping to an incorrect conclusion. Given the current info supplied by the poster, I stand by my statement that it is like the technique being used.

Peter
Hmmm the poster describes the same symptoms as the rest of us (accidentally flashing brights while trying to use the indicator), and drives a known affected model,but I'm sure it's totally unrelated.. Cause that makes perfect sense. I'm sure the poster doesn't know how to use a blinker, and there's absolutely no way it's the same issue we are experiencing, I must be jumping to conclusions.

To the original poster. go to another dealer or follow up with crystal. I can provide you with paperwork showing the fix for the issue of needed. I wholly believe you know how to drive :)
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
27,077
Reaction score
1,490
City, State
Ottawa, Ontario area
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Hmmm the poster describes the same symptoms as the rest of us (accidentally flashing brights while trying to use the indicator), and drives a known affected model,but I'm sure it's totally unrelated.. Cause that makes perfect sense. I'm sure the poster doesn't know how to use a blinker, and there's absolutely no way it's the same issue we are experiencing, I must be jumping to conclusions.

To the original poster. go to another dealer or follow up with crystal. I can provide you with paperwork showing the fix for the issue of needed. I wholly believe you know how to drive :)
There are plenty of posts in this thread that mention the accidental flashing of the hi beams that have nothing to do with a binding or sticking lever. This signal setup is a new design to me and I'm sure, to many others as well. It takes a bit of getting used to. Just because the poster describes symptoms similar to what you believe to be the issue doesn't necessarily make it so.

Peter
 




machine4321

Active Member
Joined
March 3, 2013
Messages
207
Reaction score
7
City, State
Ontario
Year, Model & Trim Level
2017 sport
After a 2nd visit amd a nice convo, theybreplaced it. It is like butter now. Much much better
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
27,077
Reaction score
1,490
City, State
Ottawa, Ontario area
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
After a 2nd visit amd a nice convo, theybreplaced it. It is like butter now. Much much better
Now that it moves so smoothly be careful that you don't snap it off.:D:thumbsup:

Peter
 




machine4321

Active Member
Joined
March 3, 2013
Messages
207
Reaction score
7
City, State
Ontario
Year, Model & Trim Level
2017 sport
Thats exactly what happened on the first day. I foound my self not using my left turn signal as it was so hard to ise. Then I remebered it was all good.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




Thread starter Similar threads Forum Replies Date
T Towing 2013 XLT Stock 2011 - 2019 Ford Explorer Discussion 1
T 2013 Explorer Sport Whistling Stock 2011 - 2019 Ford Explorer Discussion 0
S 2013 Explorer standard vs heavy duty brakes Stock 2011 - 2019 Ford Explorer Discussion 4
C 2013 Seats in a 2011? Stock 2011 - 2019 Ford Explorer Discussion 1
M 2013 Sport random little issues Stock 2011 - 2019 Ford Explorer Discussion 7
D Defroster grille question -- 2013 Explorer XLT Stock 2011 - 2019 Ford Explorer Discussion 2
E Rear Diff Axle Seals - 2013 Explorer XLT 4wd Stock 2011 - 2019 Ford Explorer Discussion 1
G Replace 3ds Hid bulb of 2013 limited Stock 2011 - 2019 Ford Explorer Discussion 1
W 2013 explorer need help with horn disable Stock 2011 - 2019 Ford Explorer Discussion 1
F 2013 explorer key fob issues Stock 2011 - 2019 Ford Explorer Discussion 1
M 2013 Sport with P0299 code (Underboost) Stock 2011 - 2019 Ford Explorer Discussion 2
J 2013 Preventative Maintenance? Stock 2011 - 2019 Ford Explorer Discussion 1
C 2013 cooling fans off with a/c Stock 2011 - 2019 Ford Explorer Discussion 9
D 2013 Explorer alternator change Stock 2011 - 2019 Ford Explorer Discussion 5
S 2013 explorer base AC issue Stock 2011 - 2019 Ford Explorer Discussion 0
P 2013 Explorer Rims Stock 2011 - 2019 Ford Explorer Discussion 0
B Off-road capabilities of stock 2013 4WD XLT Stock 2011 - 2019 Ford Explorer Discussion 17
M 2013 Ford Explorer Dash Noise\Grinding-Not a blend door I think Stock 2011 - 2019 Ford Explorer Discussion 3
S 2013 Explorer sport airbag light on, B0002 code assistance needed Stock 2011 - 2019 Ford Explorer Discussion 2
C 2013 Power Liftgate Problem Stock 2011 - 2019 Ford Explorer Discussion 2
C 2013 check charging system fault Stock 2011 - 2019 Ford Explorer Discussion 11
W Service Advance Trac & Hill Descent fault - 2013 Stock 2011 - 2019 Ford Explorer Discussion 1
G 2013 PCM location Stock 2011 - 2019 Ford Explorer Discussion 0
R 2013 XLT Suspension? Stock 2011 - 2019 Ford Explorer Discussion 10
D 2013 Explorer Keyless Entry Not Working Stock 2011 - 2019 Ford Explorer Discussion 4
S 2013 Explorer Limited Climate Control Stock 2011 - 2019 Ford Explorer Discussion 3
R 2013 to 2019 Upper Strut Mount - Does not turn freely, normal? Stock 2011 - 2019 Ford Explorer Discussion 6
J 2013 limited front exhaust pipe break (by flex joint), what to do... Stock 2011 - 2019 Ford Explorer Discussion 10
K 2013 explorer squeaking Stock 2011 - 2019 Ford Explorer Discussion 6
G Explorer 2013 front driver side louver handle cap Stock 2011 - 2019 Ford Explorer Discussion 8
G 2013 Ford Explorer XLT Rear camera replacement Stock 2011 - 2019 Ford Explorer Discussion 13
S 2013 Rear toe link breakage Stock 2011 - 2019 Ford Explorer Discussion 18
C 2013 possible purchase questions Stock 2011 - 2019 Ford Explorer Discussion 5
G Part help - 2013 explorer sport Stock 2011 - 2019 Ford Explorer Discussion 3
E 2013 Transmission Flush Stock 2011 - 2019 Ford Explorer Discussion 24
K 2013 Explorer Sport muffler leak question Stock 2011 - 2019 Ford Explorer Discussion 7
R 2013 XLT Rear Bumper & Backup Sensor Stock 2011 - 2019 Ford Explorer Discussion 6
E 2013 Explorer Reverse and A Bang Stock 2011 - 2019 Ford Explorer Discussion 3
H 2013-2015 Explorer Sport Questions ( new to the vehicle ) Stock 2011 - 2019 Ford Explorer Discussion 3
M 2013 police interceptor misses/jerks Stock 2011 - 2019 Ford Explorer Discussion 3
J 2013 explorer XLT front caliper suspension bushings Stock 2011 - 2019 Ford Explorer Discussion 3
L 2013 Explorer XLT Radio Configuration Stock 2011 - 2019 Ford Explorer Discussion 6
C 2013 Explorer XLT Blues Stock 2011 - 2019 Ford Explorer Discussion 14
O Does the 2013 Explorer Sport have a transfer case oil cooler? Stock 2011 - 2019 Ford Explorer Discussion 4
G 2013 explorer sport radiator vs N/A V6 Stock 2011 - 2019 Ford Explorer Discussion 4
S 2013 Explorer 4wd Bushing leaking Stock 2011 - 2019 Ford Explorer Discussion 21
R HOW did my 2013 Lock me out while running? Stock 2011 - 2019 Ford Explorer Discussion 20
E 2013 Explorer Overheating Stock 2011 - 2019 Ford Explorer Discussion 4
S 2013 Ford Explorer driver seat doesn’t recline back Stock 2011 - 2019 Ford Explorer Discussion 4
J 2013 Explorer leans in curves and dips hard Stock 2011 - 2019 Ford Explorer Discussion 13
Similar threads


















































Top