2013 ford explorer replaced moonroof motor still only working partway | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

2013 ford explorer replaced moonroof motor still only working partway

ccloud9

New Member
Joined
January 20, 2023
Messages
7
Reaction score
1
City, State
north highlands
Year, Model & Trim Level
2013 ford explorer xlt
replaced moonroof motor, slides back partway and stops, shade won 't close front half
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Fix4Dirt

Get a Load O' This Guy!
Elite Explorer
Joined
December 22, 2021
Messages
4,944
Reaction score
3,560
City, State
Los Angeles, CA
Year, Model & Trim Level
1998 XLT 4x4
welcome!
 






peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
35,123
Reaction score
3,458
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
replaced moonroof motor, slides back partway and stops, shade won 't close front half
Welcome to the Forum. :wave:
Does the tilt feature work? Did the shade close all the way before you replaced the moonroof motor?

Peter
 






ccloud9

New Member
Joined
January 20, 2023
Messages
7
Reaction score
1
City, State
north highlands
Year, Model & Trim Level
2013 ford explorer xlt
Welcome to the Forum. :wave:
Does the tilt feature work? Did the shade close all the way before you replaced the moonroof motor?

Peter
Hi Peter, thanks for your response, the tilt when pushed, nothing, when pulled it opens the moonroof partway, the slide when pulled closes the panel and tilts it, the shade didn't close all the way and still doesn't, I wonder if it was a mistake buying a cheaper motor on EBAY, or the way the switches are acting, maybe the switch panel?
 






peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
35,123
Reaction score
3,458
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
There seems to be something wrong with the way things are working. For Tilt, all that you should have to do is to press and release it to open and pull and release to close it.
For the glass, to open, press and release the slide button and to close it, just pull and release the slide button.
When the moonroof has opened part way, have you tried pushing the slide button a 2nd time to see if it opens more?

Peter
 






ccloud9

New Member
Joined
January 20, 2023
Messages
7
Reaction score
1
City, State
north highlands
Year, Model & Trim Level
2013 ford explorer xlt
There seems to be something wrong with the way things are working. For Tilt, all that you should have to do is to press and release it to open and pull and release to close it.
For the glass, to open, press and release the slide button and to close it, just pull and release the slide button.
When the moonroof has opened part way, have you tried pushing the slide button a 2nd time to see if it opens more?

Peter
Hi again Peter, definitely not working right, I have tried the slide every way possible, never opens more than about halfway and when I try to close it, it gets to end and tilts it, just never closes right, seems like there's something wrong with the motor, unless somehow I installed it wrong but since it's working some that seems unlikely, would it make sense to try the motor on the right side in it's place? Not sure what to do, any ideas you have are appreciated, thanks, Carl
 






peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
35,123
Reaction score
3,458
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Hi Carl. Did you try pushing the slide button a second time once it has stopped? Under normal circumstances, it should open further. That is why I asked.
In any case, when closing it should not go into the tilt position at the end of its travel. As for interchanging the motors, I don't know if they are the same or not. Have you checked the channels in which the moonroof slides to make sure they are clear of any obstructions?
I was going to suggest giving the sliding glass partition a gentle hand but then was worried that if it did open more that it might not close.

Peter
 






ccloud9

New Member
Joined
January 20, 2023
Messages
7
Reaction score
1
City, State
north highlands
Year, Model & Trim Level
2013 ford explorer xlt
Hi Carl. Did you try pushing the slide button a second time once it has stopped? Under normal circumstances, it should open further. That is why I asked.
In any case, when closing it should not go into the tilt position at the end of its travel. As for interchanging the motors, I don't know if they are the same or not. Have you checked the channels in which the moonroof slides to make sure they are clear of any obstructions?
I was going to suggest giving the sliding glass partition a gentle hand but then was worried that if it did open more that it might not close.

Peter
Hi Carl. Did you try pushing the slide button a second time once it has stopped? Under normal circumstances, it should open further. That is why I asked.
In any case, when closing it should not go into the tilt position at the end of its travel. As for interchanging the motors, I don't know if they are the same or not. Have you checked the channels in which the moonroof slides to make sure they are clear of any obstructions?
I was going to suggest giving the sliding glass partition a gentle hand but then was worried that if it did open more that it might not close.

Peter
Hi Peter, I tried unplugging both motors and plugging back in, tried the initialization again, got worse, wouldn't open at all, the tilt was the only thing working, kept fooling with it and the slide would open about 1/2" no more, when closing, back to opening the tilt, making me crazy, the motors are the same apparently, maybe just for kicks I'll try swapping them, hard to see but don't see or feel any obstruction in tracks, not helping that it's my first experience with this and I don't understand enough about it, I need to take it in for a recall fix, maybe I'll ask if they can check and see if they can see something I don't, first I'll try swapping those motors, the only other thing would be the switches in the control panel, but sounds unlikely, this is really perplexing but I might be part of the problem, thanks for trying to help Carl
 






boominXplorer

Elite Ranger
Elite Explorer
Joined
September 16, 2002
Messages
9,613
Reaction score
1,033
City, State
Virginia Beach, Va
Year, Model & Trim Level
00 4x4 Mounty
I feel it's a leaning issue. Need to program the stops so it knows where to go. Also lubing the tracks could help if they are dry. Do those motors have a spot in the center for a hex key? If so crank it manually till it is closed all the way and restart the initialization.
 






ccloud9

New Member
Joined
January 20, 2023
Messages
7
Reaction score
1
City, State
north highlands
Year, Model & Trim Level
2013 ford explorer xlt
I feel it's a leaning issue. Need to program the stops so it knows where to go. Also lubing the tracks could help if they are dry. Do those motors have a spot in the center for a hex key? If so crank it manually till it is closed all the way and restart the initialization.
I see no external way to crank manually, wish there was because when I try to close it, hard to get it just right, starts to tilt every time, I'll keep trying the initialization, you're probably right about the learning part, I can usually figure things out if I keep at it but this has me stumped so far(have to take a break and fix a hot water leak in my wife's shower) I get real stubborn about wanting to fix things myself(born in "45 so comes with the generation I guess) I'll try for another day or two, then reluctantly ask the dealer to help, thanks for trying to help, much appreciated
 






peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
35,123
Reaction score
3,458
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
I feel it's a leaning issue. Need to program the stops so it knows where to go. Also lubing the tracks could help if they are dry. Do those motors have a spot in the center for a hex key? If so crank it manually till it is closed all the way and restart the initialization.
There is no programming for the moonroof. Press the button once and it opens to the preset distance. Press it a 2nd time and it fully opens but this will cause wind buffeting. Pull down on the button and the glass partition closes all the way. Pushing or pulling on the button will cause the glass to stop in any position.

Peter
 






boominXplorer

Elite Ranger
Elite Explorer
Joined
September 16, 2002
Messages
9,613
Reaction score
1,033
City, State
Virginia Beach, Va
Year, Model & Trim Level
00 4x4 Mounty
There's got to be a way to program zero. I bet if the OP gets his in the factory closed position and unhooks the battery for a few minutes he might be ok though.
 






peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
35,123
Reaction score
3,458
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
There's got to be a way to program zero. I bet if the OP gets his in the factory closed position and unhooks the battery for a few minutes he might be ok though.
That is one ting that hasn't been done yet. The negative battery cable disconnect.

Peter
 






ccloud9

New Member
Joined
January 20, 2023
Messages
7
Reaction score
1
City, State
north highlands
Year, Model & Trim Level
2013 ford explorer xlt
There is no programming for the moonroof. Press the button once and it opens to the preset distance. Press it a 2nd time and it fully opens but this will cause wind buffeting. Pull down on the button and the glass partition closes all the way. Pushing or pulling on the button will cause the glass to stop in any position.

Peter
If it did all that it would be great, there's something not normal, it never will open all the way and never opens or closes correctly, if the motor I bought is good, maybe the right side motor is bad? I never used the moonroof the 7 yrs I have had it, it leaked water 2 or 3 yrs ago through the control panel so I taped it at the top(of course I took the tape off to try to get it working), found the left side drain plugged, probably the problem initially, maybe I need to try replacing both motors? decided to get it working so I could trade or sell it, clearly this is not a typical situation
 






mghureau

New Member
Joined
March 30, 2008
Messages
1
Reaction score
0
City, State
New Hampshire
Year, Model & Trim Level
2002 Eddie Bauer
If it did all that it would be great, there's something not normal, it never will open all the way and never opens or closes correctly, if the motor I bought is good, maybe the right side motor is bad? I never used the moonroof the 7 yrs I have had it, it leaked water 2 or 3 yrs ago through the control panel so I taped it at the top(of course I took the tape off to try to get it working), found the left side drain plugged, probably the problem initially, maybe I need to try replacing both motors? decided to get it working so I could trade or sell it, clearly this is not a typical situation
There is a procedure for re-initializing the moonroof motor and is explained in the service manual. If you google "2013 explorer moonroof motor reset procedure", you will find it. Good luck.
 






ccloud9

New Member
Joined
January 20, 2023
Messages
7
Reaction score
1
City, State
north highlands
Year, Model & Trim Level
2013 ford explorer xlt
I've tried that procedure many times with no luck, but thanks
 






Top