2013 PIU Radio question | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

2013 PIU Radio question

MartinLG3

New Member
Joined
April 9, 2005
Messages
6
Reaction score
0
City, State
Metairie, LA
Year, Model & Trim Level
'13 Explorer PIU
Just purchased a 2013 PIU and I cant seem to get the radio to work. The only buttons that work on the head unit are MENU and CLOCK. I got FORSCAN and a cable but cant see anything that would fix the issue, reset the RTM but no luck. Is this a factory option to disable the radio in these units? TIA
 


Holiday Special! Join the Elite Explorers $20 for 2 years! Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




technerd

New Member
Joined
September 12, 2021
Messages
4
Reaction score
4
City, State
Coatesville, PA
Year, Model & Trim Level
2014 PIU 3.5 Ecoboost
I don't think that's an option. Just making sure, you've hit the power button in the center of the volume knob? Turned up the volume? Does the screen show anything, like a radio station? Or black? Or just the clock?
 




MartinLG3

New Member
Joined
April 9, 2005
Messages
6
Reaction score
0
City, State
Metairie, LA
Year, Model & Trim Level
'13 Explorer PIU
I don't think that's an option. Just making sure, you've hit the power button in the center of the volume knob? Turned up the volume? Does the screen show anything, like a radio station? Or black? Or just the clock?
Yep, pressing the power button, it blinks like it’s coming on but nothing works. Just shows date and time banner across the top. Tried replacing the receiver but that didn’t help either.
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
31,959
Reaction score
2,519
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Just purchased a 2013 PIU and I cant seem to get the radio to work. The only buttons that work on the head unit are MENU and CLOCK. I got FORSCAN and a cable but cant see anything that would fix the issue, reset the RTM but no luck. Is this a factory option to disable the radio in these units? TIA
Do you have Sync? 4" screen?

Peter
 








peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
31,959
Reaction score
2,519
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3








Top