2014 Sport hesitation after battery change | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

2014 Sport hesitation after battery change

Fz09chic

New Member
Joined
August 19, 2018
Messages
1
Reaction score
0
City, State
Estero, FL
Year, Model & Trim Level
2014 Explorer Sport
Hi everyone!
On Monday the battery in my Expo Sport died and I replaced it. I did not plug it in to an alternative source while changing it - my bad. Since the battery change, I occasionally notice hesitation on acceleration, more so when it's cold. I've done the vent to atmosphere mod and when it hesitates it does not build boost at all. I hear it release, build, release, build etc until I release the throttle. Is it the mod? Did I erase the mapping with the battery change? I have an OBD scanner and will check for codes later but wanted to see if anyone else had this problem. Thanks!
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
31,978
Reaction score
2,523
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3




Top