2017 XLT, 2.3L ecoboost AWD tranny concerns | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

2017 XLT, 2.3L ecoboost AWD tranny concerns

john gorsuch

Member
Joined
August 2, 2017
Messages
21
Reaction score
0
Location
New kensington, pa
City, State
new kensington, pa
Year, Model & Trim Level
2017 explorer XLT
Hey folks, not sure how many out there have the 2.3L ecoboost motor, but I am experiencing weird things with the tranny. Lately and it seems to be happening more, when I go in reverse out my driveway, I come to a stop, and shift into Drive, not sport, the tranny seems to take a moment and then dumps into drive and then goes...a slight clunk. I also notice more of a delayed shift between 2nd and 3rd. Lastly I also noticed going up a longer hill it seems to search for a gear and acts like a pulsation at times. Now this explorer doesn't even have 2,000 miles on it yet. Is it how I am driving it?? or do you think its a shift issue?? no check engine lights, no other issues, good gas mileage. Any suggestions would be appreciated, I am thinking about calling dealer tomorrow.
 
<



whimsey

Well-Known Member
Joined
April 6, 2017
Messages
105
Reaction score
10
City, State
sparta, nj
Year, Model & Trim Level
2017 XLT
We have a 2017 2.3 XLT and twice when trying to accelerate rapidly due to traffic from a dead stop there was a dead
zone with the pedal pushed all the way down. I had to let off it and go back down not pushing it as far down then it accelerated fine. It also happened once at speed when trying to accelerate with the pedal floored. It had under 7,000 mile on the new Explorer. Perhaps there is a computer glitch. Since we can see the TSB's for our new vehicles I'll check to see if there is a TSB concerning transmission shifting. Or perhaps the transmission is still "learning". Otherwise it's been a great vehicle and a blast to drive.

Whimsey
 
<



cwescapexlt4x4

Explorin' the Desert SW
Elite Explorer
Joined
May 3, 2005
Messages
1,406
Reaction score
62
City, State
Litchfield Park, AZ area...
Year, Model & Trim Level
2021 King Ranch 4wd 3.0T
I'd certainly take them to the dealer, sounds like some issue for sure.
 
<



Rd111

Member
Joined
July 2, 2017
Messages
11
Reaction score
0
Year, Model & Trim Level
2016, explorer xlt 2.3l
Is your vibration anything like the video in this thread?

http://www.explorerforum.com/forums/index.php?threads/2-3l-rattle.464266/

I've had folks message me indicating they also have these issues. Ford claims the noises / vibrations in the drive line are "apparent in vehicle". I brought my explorer into two different dealers and they both came to the same conclusion. Ford opened a global inquiry on this issue, no resolution yet.
 
<



Top