2020 Explorer Starting Problems | Page 5 | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

2020 Explorer Starting Problems

Billfishing

New Member
Joined
September 22, 2022
Messages
8
Reaction score
4
City, State
Orlando, Florida
Year, Model & Trim Level
2020, Explorer ST
I'm guessing that you are replying to thedanman? If so, he was last seen here on December 18, 2021, so may no longer be following this thread.

Peter
I will chime in here. My 2020 ST has a bit of what everyone is noting. The difference is my remote start will not override the issue. When the tart issue occurs and I try to override, all it does is the blinkers flash 2 times and the horn beeps.

When mine does not start, I get all the alerts that my support fictions like hill descent, traction control etc are not operational and the start button flashes. I have had mr vehicle at ford for over a month. They have been able to recreate the issue many times but every fix ends up not working. Most of my modules have been replaced along with all ground wires cleaned and the battery relay box replaced.

If anyone out there has had this frustrating starting situation repaired please do tell.
 






thedanman

Member
Joined
November 19, 2018
Messages
32
Reaction score
8
City, State
Colorado
Year, Model & Trim Level
16 Plat
20 ST
77 F150
I will chime in here. My 2020 ST has a bit of what everyone is noting. The difference is my remote start will not override the issue. When the tart issue occurs and I try to override, all it does is the blinkers flash 2 times and the horn beeps.

When mine does not start, I get all the alerts that my support fictions like hill descent, traction control etc are not operational and the start button flashes. I have had mr vehicle at ford for over a month. They have been able to recreate the issue many times but every fix ends up not working. Most of my modules have been replaced along with all ground wires cleaned and the battery relay box replaced.

If anyone out there has had this frustrating starting situation repaired please do tell.
Hi Bill, I'm the one that remote starting works for, but I don't have the same symptoms as you. I don't get the hill descent/tract control lights, and my blinkers/horn don't flash/beep. My headlights turn on and off very rapidly as well as the start button led and the leds above near the cockpit lights, etc. Still, I wish you luck it getting it sorted and would beg that you let me know if you find a resolution and I will do the same for you. I've had it in again recently and they reproduced the issue but still no fix.
 






Billfishing

New Member
Joined
September 22, 2022
Messages
8
Reaction score
4
City, State
Orlando, Florida
Year, Model & Trim Level
2020, Explorer ST
Hi Bill, I'm the one that remote starting works for, but I don't have the same symptoms as you. I don't get the hill descent/tract control lights, and my blinkers/horn don't flash/beep. My headlights turn on and off very rapidly as well as the start button led and the leds above near the cockpit lights, etc. Still, I wish you luck it getting it sorted and would beg that you let me know if you find a resolution and I will do the same for you. I've had it in again recently and they reproduced the issue but still no fix.
I will make sure I do report out if issue is solved
 






peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
34,438
Reaction score
3,275
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3






Top