2DIN-Install 01' Explorer Question | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

2DIN-Install 01' Explorer Question

evergreen

Member
Joined
May 16, 2006
Messages
13
Reaction score
0
City, State
Detroit, Michigan
Year, Model & Trim Level
2001 Ford Explorer XLT
Ive got the IVA-W205 installed working properly just the mounting kit i had purchased doesn't seem to want to fit. Its the Scosche FD1330, it's a piece of crap. way to flimsy and cheap. so i was wondering if there were any other mount kits out there. right now my HU is basically free floating other than the slide and the pannel pushing on it. (does anyone know any good ways of securing it better?) and also if you look closely in this picture i botched up the panel a little bit. the texture is like a rubbery kinda feel, is there anything out there i can repair this with? other than peeling it all off and painting it another color? thanks, steve.

--
p1010842lf8.jpg
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





here's the smaller version of the same picture. :p:
 

Attachments

  • p1010842lf8.jpg
    p1010842lf8.jpg
    101.1 KB · Views: 1,577






very nice.
 






I am not exactly sure how your opening compares to my 3rd gen, but you might look into fabbing your own trim/dash kit using ABS plastic. That's what I did for mine and it turned out nice.
 






ouch...this is what I was afraid of doing to my ex...whered ya order your mounting kit from?
 






Believe you can get one from scoshe.
 






I have the Scosche kit in my Ex with Alpine's IVA-W200. The problem I am having is the trim piece sticks the face when it opens. I'm thinking of trying BestKits DD kit. When I get around to it.

This might be a dumb question, but did you use the iso-mount brackets? It looks like it sits further back then mine.
721235.jpg
 






yea i used the ones that came with the mounting kit. but for some reason i cant get it to stay level or straight for that matter. feels like somethings pushing it left or right... i dunno what i'm gonna do.
 






i have the iva-w205 in my 04 ex and it is iso mounted. the kit is made by american international. i got it from tweeter. it looks perfect in there. i will try to get a pic posted up in here.
 






I have the Scosche kit in my Ex with Alpine's IVA-W200. The problem I am having is the trim piece sticks the face when it opens. I'm thinking of trying BestKits DD kit. When I get around to it.

This might be a dumb question, but did you use the iso-mount brackets? It looks like it sits further back then mine.
721235.jpg

how did you get that wallpaper on there? can the w205 have wallpapers too do you know?
 






Yea you can have wallpaper just goto Alpine's I-Personalize site and register. Then its just as simple and downloading and burning to CD.

So I'm upgrading to the IVA-W205 and was curious how secure these kits are. How or what do they mount to? The last Scosche kit I used to install my D310 didn't seem to secure...I do some trail driving for camping trips/hunting, nothing to hardcore but dirt road style, rough and bumpy, and I really don't want to trash my HU or dash with something thats not strong and secure.
 






mine is iso mounted and then the kit has 2 screw holes at the bottom to mount to the factory mounting location. it is very secure, doesnt move at all.

how do i put an image in here? i have a pic of mine installed but i domnt know how to put a pic in here.
 






mine is iso mounted and then the kit has 2 screw holes at the bottom to mount to the factory mounting location. it is very secure, doesnt move at all.

how do i put an image in here? i have a pic of mine installed but i domnt know how to put a pic in here.

What install kit did you use? I'm just curious if one kit is better that the others.
 






i have the iva-w205 in my 04 ex and it is iso mounted. the kit is made by american international. i got it from tweeter. it looks perfect in there. i will try to get a pic posted up in here.


NM guess I should read more carefully....
 












i guess this shouldn't be put into '01's, i knew i would have to dremel out my dash but it just doesn't seem to want to fit properly. Ive done all that i could do. My cousin does radio installs for a living ect. and he says he doesn't know what to do :\
 






Here is mine installed. I really like it....

471641_5_full.jpg


Here is a shot of how I mounted it....

471641_6_full.jpg


I used heavy stapping from the ISO screw holes attached to points on inside the dash. I just didnt feel that the mounting kits where strong/secure enough. This way also has the added benifit of pissing off would be theives.
 






So disregard the mounting kits and the factory mounting bracket and just use straps.. hmm thats actually a good idea, what kinda mounting kit did you have cause faceplate thing from the kit looks different from the scochse one i own. or any other for that matter. thank you for the good idea
 






i just noticed you own a 2000 :\ heh i guess we will see tuesday
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





what kinda mounting kit did you have cause faceplate thing from the kit looks different from the scochse one i own. or any other for that matter. thank you for the good idea

Its just a piece of thin trim plastic, cut and attached with a little 3m contact spray, the radio bezel sits right against it... I don't really know where they get it but I got it from a friend at a local install shop.
 






Back
Top