#3 misfire HELP!!!! | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

#3 misfire HELP!!!!

Johnwimber1

Member
Joined
February 1, 2021
Messages
29
Reaction score
1
City, State
Lake Elsinore, CA
Year, Model & Trim Level
1999 Ford Explorer xlt
Hey guys so I have a #3 misfire on the 5.0 I’ve changed wire spark plugs coils even injector and still have the miss I can’t figure this thing out for the life of me and yes I checked compression and it’s normal what else possibly could be wrong? It’s weird because it going in and out of having a miss it isn’t constant but it’s pretty bad when it is I’ve tried everything please help thanks guys
 






410Fortune

Truck Season!!
Staff member
Moderator
Joined
August 3, 2000
Messages
28,695
Reaction score
5,040
City, State
NORTH IDAHO, 7B
Year, Model & Trim Level
B2 "Slightly" Modified
Callsign
FOURTEN
I suspect a leaking EGR valve
Do you have the ability to do a smoke test?

You replaced just the one injector?
Have you checked fuel pressure?

Had a 2000 Ranger we converted to a 306, brand new Jasper reman engine. Used new just about everything on the build, all new gaskets when installing all the explorer parts onto the Jasper longblock. I have sealed up many many 5.0. Once we put the truck together everything was perfect for the first couple hundred miles. Then it developed a misfire. Like you we replaced the injectors, the coils, the plugs, wires, checked compression, leak down test, fuel pressure, etc etc etc. Finally did a smoke test and found a leaking EGR valve. The actually EGR valve on the back of the manifold had a pinhole leak. Misfire solved!

The PCM kept telling us misfire cyl 7

A new EGR valve and gasket solved it

In all my years of building and maintaining these 5.0 trucks that was the first time I have ever seen that.
Smoke test was how they found the leaking valve (truck was now 8 hours away from me)
 






Top