91 explorer body and transmission/ 94 engine | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

91 explorer body and transmission/ 94 engine

kumar_svt

Member
Joined
February 22, 2015
Messages
18
Reaction score
0
City, State
East Los Angeles, CA
Year, Model & Trim Level
1991 Ford Explorer 5SPD R
I got a used 94 explorer engine for my 91 explorer. The engine was incomplete, because the intake manifold didnt come with it; so i put my old 91 intake manifold on the 94 engine. Everithing bolted on right. Plugged up all electrical, but i didnt lable the vacuum hoses to where they go and join together with "t" fittings. I turned it on, and its alive. The only problem it idles at 1500 and it goes down alittle after i let it warm up, but when i accelarate; the rpms go up to 2000 and stays there.
 
<



alfilrey

Member
Joined
September 20, 2012
Messages
27
Reaction score
1
City, State
San Luis Sonora
Year, Model & Trim Level
1992 Ford Explorer
REVIEW OF NEW CONNECTIONS HOSES VACUUM CHECK THAT ARE NOT BROKEN; ALSO, FOR THAT, YOU SHOULD INSPECT IAC VALVE, IS LIKELY TO BE THAT FAILURE TO HAVE. IF YOU CAN DO IT, remove and clean it.
 
<



xplorernewb

Well-Known Member
Joined
May 6, 2014
Messages
165
Reaction score
1
City, State
washington state
Year, Model & Trim Level
91 ford explorer sport
check your throttle cable from the tb to the pedal to make sure it isnt binding or stuck under the carpet if you have it. seen that happen a couple times
 
<



Top