93 Explorer, (EGR low voltage). Won't pass smog. | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! Once registered you can join the Elite Explorers to eliminate ads from the website.

93 Explorer, (EGR low voltage). Won't pass smog.

willyd

New Member
Joined
September 21, 2008
Messages
2
Reaction score
0
City, State
Southern California
Year, Model & Trim Level
93 Explorer
93 Explorer not passing smog test. Check engine light on, Code 32, "EGR valve not seated; closed low voltage". I replaced the EGR valve with no luck. Please help. I got nothing... :hammer:
 



Join the Elite Explorers $20 Get rid of the ads!
Elite Explorer members see no advertisements, no banner ads, no double underlined links.
Add an avatar, upload photo attachments, and more!
. First register on the forum, then join the Elite Explorers to get rid of the ads!





Tbars4

Moderator Emeritus
Elite In Memoriam
Joined
March 4, 2007
Messages
26,353
Reaction score
70
City, State
anaheim hills,california
Year, Model & Trim Level
95 ranger 4x4/ 91 X 4x4






willyd

New Member
Joined
September 21, 2008
Messages
2
Reaction score
0
City, State
Southern California
Year, Model & Trim Level
93 Explorer
No vacuum is being aplied to the EGR valve from the EVR at any engine speed.:salute:
 












Sams01XplrSprt

Southern Cali Explorer
Joined
November 14, 2004
Messages
14,169
Reaction score
3
City, State
Newport Beach California & Bay Area California
Year, Model & Trim Level
2001 Sport (sold)
welcome
 






BrooklynBay

Moderator & long time member.
Staff member
Moderator
Elite Explorer
Joined
November 11, 2005
Messages
55,499
Reaction score
799
City, State
Brooklyn, NY
Year, Model & Trim Level
88 89 93 95 96 Aerostars












Top