93 motor swap issue | Page 5 | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! Once registered you can join the Elite Explorers to eliminate ads from the website.

93 motor swap issue

Josh P

Shaggin Wagon
Elite Explorer
Joined
February 18, 2015
Messages
2,450
Reaction score
1,072
City, State
Phoenix Az
Year, Model & Trim Level
1991 aerostar



Join the Elite Explorers $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links.
Add an avatar, upload photo attachments, and more!
.



lifeguard379

Explorer Addict
Joined
July 10, 2004
Messages
1,299
Reaction score
12
City, State
sacremento,ca
Year, Model & Trim Level
93 eddie bauer 2 door
So does anyone think i can get the 5 years back fees dropped because there not doing late fees right now? Lol
 






410Fortune

Truck Season!!
Staff member
Moderator
Joined
August 3, 2000
Messages
28,244
Reaction score
4,163
City, State
NORTH IDAHO, 7B
Year, Model & Trim Level
B2 "Slightly" Modified
Callsign
FOURTEN
What I do is sell the truck to my wife then no more late fees for letting the registration lapse
FYI in some states you are allowed to "gift" a vehicle so you can put down you sold it for $0 if you want
 






lifeguard379

Explorer Addict
Joined
July 10, 2004
Messages
1,299
Reaction score
12
City, State
sacremento,ca
Year, Model & Trim Level
93 eddie bauer 2 door
California makes you pay back reg usually when sold.
 






lifeguard379

Explorer Addict
Joined
July 10, 2004
Messages
1,299
Reaction score
12
City, State
sacremento,ca
Year, Model & Trim Level
93 eddie bauer 2 door
Well finally got around to trying to smog it (over 650 hours of ot last year I didn't have time) it is running nicely. But failed with really high NO. And gross evap leak. Evap has been fixed. didn't realize I broke the line from tank to frame when installing new fuel pump. Would that also be my high NO problem? Besides that I'm thinking cats or o2 sensors. Anyway hope everyone that has had advice or has advice is doing well. Thanks for any input.
 






lifeguard379

Explorer Addict
Joined
July 10, 2004
Messages
1,299
Reaction score
12
City, State
sacremento,ca
Year, Model & Trim Level
93 eddie bauer 2 door
Any ideas? And can't figure out hi egr voltage
 






410Fortune

Truck Season!!
Staff member
Moderator
Joined
August 3, 2000
Messages
28,244
Reaction score
4,163
City, State
NORTH IDAHO, 7B
Year, Model & Trim Level
B2 "Slightly" Modified
Callsign
FOURTEN
You are getting a code for the EGR?
What is the code
Did you clear the code and then it comes back?
 






lifeguard379

Explorer Addict
Joined
July 10, 2004
Messages
1,299
Reaction score
12
City, State
sacremento,ca
Year, Model & Trim Level
93 eddie bauer 2 door
You are getting a code for the EGR?
What is the code
Did you clear the code and then it comes back?
Ya its egr voltage high and exhausted pressure to high. I pulled the cats of and washed them In soapy water. Stuff did come out of them. Don't know if it will actually help or not.
 






410Fortune

Truck Season!!
Staff member
Moderator
Joined
August 3, 2000
Messages
28,244
Reaction score
4,163
City, State
NORTH IDAHO, 7B
Year, Model & Trim Level
B2 "Slightly" Modified
Callsign
FOURTEN
what is the actual code(s)?

EGR voltage high
EGR flow or pressure too high?
These could both be rather simple to fix and have nothing to do with clogged converters
 






lifeguard379

Explorer Addict
Joined
July 10, 2004
Messages
1,299
Reaction score
12
City, State
sacremento,ca
Year, Model & Trim Level
93 eddie bauer 2 door
Ok finally got the codes. 452 speed sensor, 337egr above max voltage and 336 egr voltage high than expected.
 












Josh P

Shaggin Wagon
Elite Explorer
Joined
February 18, 2015
Messages
2,450
Reaction score
1,072
City, State
Phoenix Az
Year, Model & Trim Level
1991 aerostar
Any speedometer symptoms? Like jumping needle or not displaying an accurate speed? I think either the sensor on top of the rear axle is bad or an issue with the psom
 






lifeguard379

Explorer Addict
Joined
July 10, 2004
Messages
1,299
Reaction score
12
City, State
sacremento,ca
Year, Model & Trim Level
93 eddie bauer 2 door
Well thats because I need a longer cable. Dose the speed sensor have anything to to with the egr? Do 1st gens actually need them for the computer?
 






Josh P

Shaggin Wagon
Elite Explorer
Joined
February 18, 2015
Messages
2,450
Reaction score
1,072
City, State
Phoenix Az
Year, Model & Trim Level
1991 aerostar
Well thats because I need a longer cable. Dose the speed sensor have anything to to with the egr? Do 1st gens actually need them for the computer?
The ecm uses the speed sensor to calculate fuel economy, 3-4 shift, tcc lockup for the auto trans and some other stuff I'm forgetting at the moment. Have you removed the egr valve to inspect it for carbon buildup?
 






lifeguard379

Explorer Addict
Joined
July 10, 2004
Messages
1,299
Reaction score
12
City, State
sacremento,ca
Year, Model & Trim Level
93 eddie bauer 2 door
I have a 5 speed and all new sensors and pigtails. And it a 1st gen so didn't think the broken speed sensor would be a check engine light issue with egr problem.
 






410Fortune

Truck Season!!
Staff member
Moderator
Joined
August 3, 2000
Messages
28,244
Reaction score
4,163
City, State
NORTH IDAHO, 7B
Year, Model & Trim Level
B2 "Slightly" Modified
Callsign
FOURTEN
Not all 93’s had egr
Does your engine have egr? I mean I know you have egr codes but is there actually a egr system on the engine

If your pcm was ever replaced or repaired it maybe looking for an egr system that is not there

First gens definitely need a speed sensor the computer needs to know you are
Moving
The speedometer in the dash is cable driven but it sits inside the vss which is an electronic sensor in the trans (t case).
The vss is gear driven and the drive gear gets worn which can cause the bouncing needle or erratic speedo
 






lifeguard379

Explorer Addict
Joined
July 10, 2004
Messages
1,299
Reaction score
12
City, State
sacremento,ca
Year, Model & Trim Level
93 eddie bauer 2 door
Well it passed everything but high nox. And the smog shop said do to the low levels of the other gasses the cat was probably working fine. I found my fuel pump regulator vacuum line was off but the smog guy said that probably helped. Does that make any sense?
 






ChildIdenticant

Elite Explorer
Joined
January 14, 2016
Messages
350
Reaction score
219
City, State
california
Year, Model & Trim Level
1994 explorer
After your smog is sorted this time, consider changing reg details for this vehicle to neighboring amador county or one of the other program area 3 regions that are so close to Sacramento.
 






BKennedy

Elite Loser
Staff member
Moderator
Elite Explorer
Joined
November 29, 2000
Messages
9,012
Reaction score
2,386
Location
USA
City, State
San Diego, PRofK
Year, Model & Trim Level
1994 XLT
After your smog is sorted this time, consider changing reg details for this vehicle to neighboring amador county or one of the other program area 3 regions that are so close to Sacramento.
But, only if you actually move to one of those regions....

I thought 1994 was the only 1st gen with VSS. It doesn't have anything to do with shift points. It's got something to do with fuel line control. I went through VSS when I installed my Atlas II. I had a new VSS unit made up by a speedo company with cable on both sides.
 



Join the Elite Explorers $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links.
Add an avatar, upload photo attachments, and more!
.



lifeguard379

Explorer Addict
Joined
July 10, 2004
Messages
1,299
Reaction score
12
City, State
sacremento,ca
Year, Model & Trim Level
93 eddie bauer 2 door
I'm thinking new fuel pressure regulator. If the vacuum line being off helped. That make sense?
 






Top