• Register Today It's free! This box and some ads will disappear once registered!

94 Aerostar with a 4.0L has no power going to the fuel pump.

dgetty

New Member
Joined
August 26, 2010
Messages
2
Reaction score
0
City, State
Neosho, Wisconsin
Year, Model & Trim Level
94 Aerostar AWD
Hello and thanks in advance. Any help would be greatly appreciated. I have a 94 aerostar that just died on me the other day. I have no power at the fuel pump. The fuse at the inertia switch is good but there is no power there either and it has not been triggered. The fusible link at the starter relay seems to be good also. This van is a rusted out beater with 192k on it and I dont want to invest any $ in it. If I can rig it to run, great. If it will cost much, I will probably scrap it:( I have a Haynes manual but it doesnt seem to be that helpful. I should mention that the other day I checked the fuse by the inertia switch with a test light and it had power at both sides of the fuse but now there is no power at all. Thanks again.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




rhauf

Explorer Addict
Joined
November 1, 2005
Messages
1,249
Reaction score
5
City, State
Ca
Year, Model & Trim Level
91,93,98,&02 Exploders
why not just put the fuel pump on a switch? (or a headlight relay from the auto parts store, and trigger that relay with some key-on power, such as the power stereo turn-on wire)
 




BrooklynBay

Moderator & long time member.
Staff member
Moderator
Elite Explorer
Joined
November 11, 2005
Messages
54,886
Reaction score
607
City, State
Brooklyn, NY
Year, Model & Trim Level
88 89 93 95 96 Aerostars
Welcome to this forum! Check the fuel pump relay. Do you see a check engine light when you turn the key to activate the electrical system? If not, then it could be the PCM relay or a ground wire near the battery that is the ground feed for the PCM.
 




dgetty

New Member
Joined
August 26, 2010
Messages
2
Reaction score
0
City, State
Neosho, Wisconsin
Year, Model & Trim Level
94 Aerostar AWD
Thank you both for your replies. I thought about running a switch or even jumping the fuel pump but im not sure what wires to jump at the plug. The connector has a black, red, yellow and another slightly smaller black with a white stripe. There is no power at the connector. Im also not sure which is the fuel pump relay or the pcm relay for that matter. I tried swapping the three relays around under the plastic cover behind the battery and that made no difference. The cel does come on and stay on with the key in the run position. I have not checked any grounds yet but it cranks over no problem. I guess im looking for specific locations of these things and specific wire colors if at all possible. Even proper ways to check things out would be helpful. I have a multimeter but dont know how to use it all that well. Thanks again !
 




BrooklynBay

Moderator & long time member.
Staff member
Moderator
Elite Explorer
Joined
November 11, 2005
Messages
54,886
Reaction score
607
City, State
Brooklyn, NY
Year, Model & Trim Level
88 89 93 95 96 Aerostars




backfrmcolorado

Well-Known Member
Joined
February 21, 2010
Messages
555
Reaction score
0
City, State
Commerce Twp, MI
Year, Model & Trim Level
'94 Eddie B explodwhore
i have the same problem on my 94 X. i lost all power to my fuel pump and have no spark.
what could it be?
 




BrooklynBay

Moderator & long time member.
Staff member
Moderator
Elite Explorer
Joined
November 11, 2005
Messages
54,886
Reaction score
607
City, State
Brooklyn, NY
Year, Model & Trim Level
88 89 93 95 96 Aerostars




backfrmcolorado

Well-Known Member
Joined
February 21, 2010
Messages
555
Reaction score
0
City, State
Commerce Twp, MI
Year, Model & Trim Level
'94 Eddie B explodwhore
pcm is good and i have a CEL. i blew the 30 amp fuse for the PCM the is in the fuse box under the hood. I looks like it was the only fuse never replaced in the fuse box.. i now have the spark situation figured out but still no fuel. The fuel pump relay and fuse are both good. I cant tell if i have power at the fuel pump to to the fact that i cant turn the key on and get iunder the truck fast enuf b4 he pump power would turn off.
 




Top