'94 Exp codes 172, 327, 332, 538, & 543 | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership!
    If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

'94 Exp codes 172, 327, 332, 538, & 543

martinh67

Member
Joined
December 10, 2008
Messages
18
Reaction score
0
City, State
Virginia
Year, Model & Trim Level
'94 XLT
Recently replaced PFE and and cleaned IAC and MAF. She was running great for about 200 miles. Now she is running rough at idle with CEL and the following codes:

KOEO
327 - DPFE or EVP circuit below minimum voltage of 0.2 volts.
543 - When the PCM commanded the fuel pump on, voltage was not detected on FPM.

CM
327 -
332 - EGR valve opening not detected.

KOER
172 - HEGO sensor circuit indicates system lean (right side)
327 -
538 -Insufficient RPM change during KOER dynamic response test/ Operator error.

I checked the input voltage the to the EGR vacuum regulator and read 14VDC. Kinda high I think.

My next step would be to replace the EGR valve. I also replace the EGR vacuum regulator. All vacuum lines seem good.

Should I replace the EGR valve? I'm afraid of throwing $$ into something that can be simple. Any ideas?
 






MrShorty

Explorer Addict
Joined
December 27, 2001
Messages
5,078
Reaction score
19
City, State
Spanish Fork, UT
Year, Model & Trim Level
92 XLT and '87 Bronco II
KOEO 327: KOEO codes almost have to be electrical. The EGR valve itself isn't tested during the KOEO test, so I wouldn't expect this to be a fault in the EGR valve, and, where there isn't any engine vacuum, a fault in the EVR solenoid really wouldn't explain a KOEO 327. It almost has to be a fault in the PFE sensor circuit. After a few months, do you feel like you can assume the PFE is still good? Have you checked the wiring between the PFE and the PCM?

KOEO 543: Indicates some fault in the fuel pump circuit/fuel pump monitor circuit. Where the engine runs, obviously the pump is running. There could still be an intermittent fault in the fuel pump circuit, and this could be contributing to a rough running if the fault prevents the pump from supplying sufficient fuel. May not explain everything your seeing, but I'd look into it in case it's an intermittent that is waiting to become a permanent fault and leave you stranded somewhere.

KOER 327, CM 327, & 332: Resolve KOEO 327 first, and these EGR codes may go away.

KOER 538: Almost always operator error, indicating that you neglected the "goose" test at the appropriate time. Review test instructions and repeat.

KOER 172: I suspect this might be operator error, especially since you don't report a similar CM O2 sensor code. The O2 sensor must be preheated before the KOER test, and this often indicates that the O2 sensor was too cold. Run engine and repeat KOER test to see if this code resolves itself.

14 V power supply to the EVR solenoid doesn't seem too unusual, especially with the engine running. Supply to the EVR solenoid should be battery voltage, and 14 V could just be meter error or what the alternator outputs. What does your meter give you for battery voltage?

In conclusion: I'd go back to the PFE sensor circuit and make sure all connectors are making a good connection and make sure this circuit looks right.
 






Top