94 explorer overdrive servo leak | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

94 explorer overdrive servo leak

Shinryu

Member
Joined
March 3, 2010
Messages
17
Reaction score
0
City, State
Chicago,IL
Year, Model & Trim Level
'94 4X4 Eddie Bauer
hi i have a 94 ford explorer with 185k i recently notice low transmission fluid levels and shift problem when cold so i got under the truck with the engine running and saw that the od servo had a leak. when i top off with ATF everything is fine no shift problems. so should i just replace the O-ring on the od servo or do you think i have bigger problems?

thank you
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




<



<



swetrid

Explorer Addict
Joined
September 30, 2010
Messages
1,888
Reaction score
3
City, State
Reading Pa
Year, Model & Trim Level
1999 Eddie Bauer
You can try the oring it should fix it, just make sure the cover is in good condition.
 
<



Shinryu

Member
Joined
March 3, 2010
Messages
17
Reaction score
0
City, State
Chicago,IL
Year, Model & Trim Level
'94 4X4 Eddie Bauer
thanks guess it wont hurt to order the covers just in case lol
 
<



huntman58

Well-Known Member
Joined
February 13, 2007
Messages
722
Reaction score
4
City, State
Fremont calif.
Year, Model & Trim Level
2013 Dodge Advenger
if every thing is working as it should then I would say do the O ring but if there are other problems that you did not say then have it checked out
 
<



Shinryu

Member
Joined
March 3, 2010
Messages
17
Reaction score
0
City, State
Chicago,IL
Year, Model & Trim Level
'94 4X4 Eddie Bauer
nah thats all that i notice at the moment
 
<



Top