94 explorer trans probs | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

94 explorer trans probs

WILLY BILL

New Member
Joined
January 5, 2010
Messages
2
Reaction score
0
City, State
Larue TEXAS
Year, Model & Trim Level
1994 Explorer
ok i have 94 explorer 5 speed and i push the clutch in and it will start but with it in neutral it will catch like is in gear and die and when in any gear it will jump like its slipping and then get in a bind and die and what would happen if u put gear lube in the trans?
 




shaggymane

Well-Known Member
Joined
March 4, 2008
Messages
317
Reaction score
2
City, State
topeka, kansas
Year, Model & Trim Level
91 navajo
ok i have 94 explorer 5 speed and i push the clutch in and it will start but with it in neutral it will catch like is in gear and die and when in any gear it will jump like its slipping and then get in a bind and die and what would happen if u put gear lube in the trans?

First thing to check is the fluid level in your clutch fluid reservoir. It a small white cylinder on the fire wall, drivers side, between the hood hinge and the fender. Unscrew the cap, pull the black cup diaphragm out. Should be about half full. Than stab the clutch pedal a couple a times and see if that doesn't bring the friction point back up. Works on mine.
If not your clutch or some component of the clutch is likely out.
Your 94 might have a bleed screw on it but my 91 doesn't.
Got nothing to do with your tranny fluid level, unless you also hear loud rasping noises.
 




WILLY BILL

New Member
Joined
January 5, 2010
Messages
2
Reaction score
0
City, State
Larue TEXAS
Year, Model & Trim Level
1994 Explorer
Before it started doing that it was making a clicking noise what could that have been
 




$TheMoneyPit$

Member
Joined
December 4, 2008
Messages
46
Reaction score
0
City, State
elkton maryland
Year, Model & Trim Level
1992 mazda navajo&97 xlt
the trans doesnt take gear lube its automatic tranny fluid burnt my first five speed up like that mine got stuck in third inside the trans and didnt matter if you actually shifted the trans with the shifter it stayed in third you might want to look for another trans
 




Top