'94 Explorer XLT Fuel Relay problems | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

'94 Explorer XLT Fuel Relay problems

Robex94

New Member
Joined
March 15, 2012
Messages
4
Reaction score
0
City, State
Wichita Kansas
Year, Model & Trim Level
1994 Ford Explorer XLT
Okay, so I have been researching on here like crazy and I have found some great help on how to resolve my fuel problems, so hopefully I will be able to get some help on this one.

I have a '94 Explorer XLT 4X4 that has been intermittently failing to start and failing to continue running. It hasn't show any consistent reason for failing except for that it fails after getting warmed up.

I changed the fuel pump and EEC relay and it fired up and ran wonderfully. Then after a week they failed. So I got on here and found out that aftermarket relays are prone to fail and that I should use Ford relays. I bought some off an Explorer at a salvage yard (5 for $20 was better than 1 for $25 from Ford) and they worked wonderfully, until today when they failed me 3 separate times. So I took apart on of the aftermarket relays, stuck it closed and it fired up but ran kind of rough at 60mph. I am going a bit mad trying to figure the problem, does anyone know why a relay would continue to fail? Am I barking up the wrong tree entirely? I am pretty sure it is the relay because every time I put in a new one or jump across it my Explorer fires right up.

I am sure that I have left out information for the sake of brevity, but if anyone could help I would definitely appreciate it, and if you need any more info I will be sure to get it to you. Thanks in advance!
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





I think if it were me, I'd put a voltmeter on the fuel pump circuit next time it acts up and verify that the relay is failing open.
 






I am having the exact same problem on my 94, I tested it at the pump wiring harness(which is new) and I'm not getting power to it, except for the gauge, so I figured that my inertia switch was bad, replaced it, ran great for about 20 miles, then died again, I feel your frustration, so please let me know what you find out, and I'll let you know if I get it figured out. I have seen a lot of posts on here with similar scenarios but I haven't seen any that tried anything different than what I've already failed at.
 






Ok, been doing a whole lot of reading up on this issue, the general consensus is failing capacitors in the PCM/ECM, which is really is to check,1st disconnect battery then all you have to do is remove the passenger side "kickplate", just inside the door, remove the screw that holds the clamp in place, loosen the bolt that holds the wiring harness in place, remove harness, now here is where yours probably differs from mine, mine has 8 tiny screws that hold the cover on, I read that some have 2 T40 torque screws, but remove that plate, and viola there's the motherboard. it should be obvious if the capacitors are bad, they will either have an oily puddle around them or, be kinda domed shaped on the top, everything looked fine on mine, but maybe it'll help you solve your problem, I would suggest just buying a new PCM if they're bad, since they're about $100, unless you or someone you know is good at fixing stuff like that. I myself have no patience for it.
 






Have you tried pulling the codes? You may have a KOEO or CM code for either the primary or secondary fuel pump circuit.

If you can find the service manual they step you through the trouble shooting for trying to isolate the codes and it may be completely unrelated.

Apparently, one of the issues that can cause some of these codes fuel pump related codes are:
- Fuel pump relay
- Inertia Fuel Shutoff Switch
- Wiring Harness
- Faulty PCM
- Left/front O2 sensor short to power
 






Spray some Electronic Cleaner into sockets...worked for me....BUY relays from a junk yard????
 






Okay, sorry it has been so long, I wanted to give it a chance to fail again before I got on here to give everyone an update.

I took the case off of a couple relays and then I had a friend try to start the car while I watched them and checked the to see if they were getting power. Turns out they worked just fine, but still no fire. So then I purchased a new PCM/ECC and put it in yesterday, still no fire. So, I have replaced the computer, replaced the relays, and replaced the fuel filter.

Seems to me it has to be the fuel pump, that seem logical?

I'm wondering if there is a possibility that I missed something in the replacement of the computer, I'm really trying to avoid spending more money and not solving the problem.

When I put the new PCM in I didn't disconnect the battery, is this possible wrong? Should I have had it disconnected first? I don't know much about computer parts in cars and wondered if it needs to reset somehow. I may just be completely wrong here... Any ideas?
 






If you can verify that the pump is getting power and ground and refuses to run, then the pump's probably bad. If this is the direction you're headed, the next thing I'd do would be to go to the pump connector (on mine, it's in the driver's frame rail above the axle) and test for power and ground there.
 






You can test the fuel pump by putting 12+ Vdc to the green/yellow wire off the Fuel pump relay (Mine is 1994 Eddie Bauer). You will hear the fuel pump if its working.

Good luck. My stuck is in a no start condition. Similar issues. :(
 






Are you sure the problem is even fuel related???

Losing spark can also cause a no run condition.

Hook up a fuel gauge, and you should read ~45 psig. You should also have good fuel flow. The nicer fuel pressure gauges have bypass buttons that let gas squirt out when you press them. This is so you can verify good fuel flow. These testers have two hoses. The bypass squirter is a must have feature for fuel injection systems.

I have a Snap-On pressure tester that does all this, but they run hundreds of dollars. You should be able to pick up a good pressure tester for under $100. Just make sure it has the proper connector for you Explorer's fuel rail.
 












Link not working
 


















Back
Top