95 Cruise Control not working - need help | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

95 Cruise Control not working - need help

marragtop

Explorer Addict
Joined
April 14, 2001
Messages
2,075
Reaction score
3
City, State
balt, md
Year, Model & Trim Level
91, 92, 95, and 2000 xlts
I have a 95 XLT 4.0 AT. The cruise control stopped working. Fuses are good. Also, the cruise control light in the dash does NOT come on. What are the next steps to diagnose this, or what is the likely problem? thanks.
 






Lots of posts on this type of problem. You said your fuses are good... did you check them with a meter.... looking isn't checking. Next you need to check the BOO switch (on your brake pedal area)... its needs to be open for "cruise operation" (ie. no brake on) and you need to check your pressure switch on your master cylinder (likely candidate). It needs to be closed (ie. no resistance / short) for cruise operation (ie. no pressure on your brake). It is most likely one of these two switches .... use a meter. Finally, it could be a broken wire coming from your activation switches in your steering (ie. clock spring).
 






......ooooK > > > i have had this experience of only to find out my EXPENSIVE repair bill from a local shop was something everyone else CAN fix for themselve's if having the same "cause" of problem: I too checked all fuse's and came up with none blown..........basically, took it to my local shop for here and in a couple of hours later was called and told can pick up towards end of the day. Come to find out: Repair-Bill = to $42.85 :rolleyes: ....( oooK, thought that was sort of cheap for like 2 hour's worth of work :confused: ) . . . . then to have both rear tailight_bulb's placed in my hand's for the part's > >:mad: < < :eek: .......[ needless to say i was dumbfounded as well as pissed at my self for these cheap part's, BUT i had NO idea that the cruise control circuit was setup upon the same circuit for the "Brake_Light's" ? ! ? ! ????:confused: ] ........ this i confirmed when i got back home and placed both of these blown_bulb's back into the taillights to checkout for myself >>>and YES indeed when BOTH Brake Light's are blown or not working, the cruise control does NOT light-up / work ..... :confused: .... :mad: ..... :rolleyes: . . . . .gzzzzzzz talk about's a hard way to find out/know/learned lesson of...... :( ....{ info 2 know = NEW bulb packet for a pair of = like $3.99 give/take ....:mad: ....} ......so, think about's that BIG profit they got me for ! ! ! ! :mad: .........but, just wanted to share "MY":confused: episode to you as well as other's out there to checkout: if your cruise control decided to stop working; check BOTH Brake-Light_bulb's FIRST!!! ya just might get lucky and get off cheap, if n'ya do it yourself for being this EASY & CHEAP > > > fix .........:salute:

mr. Charles

.
 






......ooooK > > > i have had this experience of only to find out my EXPENSIVE repair bill from a local shop was something everyone else CAN fix for themselve's if having the same "cause" of problem: I too checked all fuse's and came up with none blown..........basically, took it to my local shop for here and in a couple of hours later was called and told can pick up towards end of the day. Come to find out: Repair-Bill = to $42.85 :rolleyes: ....( oooK, thought that was sort of cheap for like 2 hour's worth of work :confused: ) . . . . then to have both rear tailight_bulb's placed in my hand's for the part's > >:mad: < < :eek: .......[ needless to say i was dumbfounded as well as pissed at my self for these cheap part's, BUT i had NO idea that the cruise control circuit was setup upon the same circuit for the "Brake_Light's" ? ! ? ! ????:confused: ] ........ this i confirmed when i got back home and placed both of these blown_bulb's back into the taillights to checkout for myself >>>and YES indeed when BOTH Brake Light's are blown or not working, the cruise control does NOT light-up / work ..... :confused: .... :mad: ..... :rolleyes: . . . . .gzzzzzzz talk about's a hard way to find out/know/learned lesson of...... :( ....{ info 2 know = NEW bulb packet for a pair of = like $3.99 give/take ....:mad: ....} ......so, think about's that BIG profit they got me for ! ! ! ! :mad: .........but, just wanted to share "MY":confused: episode to you as well as other's out there to checkout: if your cruise control decided to stop working; check BOTH Brake-Light_bulb's FIRST!!! ya just might get lucky and get off cheap, if n'ya do it yourself for being this EASY & CHEAP > > > fix .........:salute:

mr. Charles

.


Got my cruise issue repaired,
found out that speed control cutoff switch was issue (the recall fird issue)

here is what I found

part number# Motorcraft SW6350
which says fits and works for the 1995 ford ranger 4.0 engine is "INCORRECT"
(after replacing this part three times)

part number# Motorcraft SW-6349 which says fits and works for the 1995 ford ranger is "CORRECT"
(after replacing this with CORRECT part one time)

SHOTGUN $ wasted to find this out

Cruise is working perfectly AGAIN after 2 years .......

hopes this helps someone else here searching for speed control (cruise control) issues
 






Back
Top