95 vs. 96 4.0 engine | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

95 vs. 96 4.0 engine

Barcuss

Member
Joined
December 18, 2004
Messages
33
Reaction score
0
City, State
Auburn Georgia
Year, Model & Trim Level
95 XLT
I picked up a 96 4.0 motor from a local junk yard but the main wiring harness is different. The connector that plugs into the ecm on the firewall has 4 rows of pins and my 95 has 3 rows of pins and there is 2 large connectors on the back side of the motor that connect close to the top of the transmission bell housing and on my 95 I only have 1 of those large connectors.

If I remove that wiring harness and replace it with my original harness will it work or could I have problems with emissions and/or problems with it running at all.
 


Holiday Special! Join the Elite Explorers $20 for 2 years! Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




corkey

Moderator Emeritus
Moderator Emeritus
Joined
January 3, 2008
Messages
6,007
Reaction score
48
Location
Sioux Narrows Canada
City, State
Elite Canuck,multiple ifs offender,, and musky maniac,, i wheel and i fish,,
Year, Model & Trim Level
99 xls,96 xl,91,08 Ranger
the sensors and intake from the 95 engine have to be put on the 96 motor as the 95 is obd 1 , and the 96 is obd 2 ,,

they may have different values on the sensors that make the gauges wrong,,and affect the way the ecm operates,,
 




Vic_Ferrari2002

Well-Known Member
Joined
January 9, 2012
Messages
134
Reaction score
1
City, State
Chambersburg PA
Year, Model & Trim Level
'97 Explorer Sport
the sensors and intake from the 95 engine have to be put on the 96 motor as the 95 is obd 1 , and the 96 is obd 2 ,,

Are the '95's that have OBD II all after a certain date?
 




marragtop

Explorer Addict
Joined
April 14, 2001
Messages
2,075
Reaction score
0
City, State
balt, md
Year, Model & Trim Level
91, 92, 95, and 2000 xlts
I believe 95 was the transition year from OBD I to II. The wiring harness for OBD I should have the OBD I connector and spout connector on it inside the engine compartment. OBD II will not have these connectors.
 




Barcuss

Member
Joined
December 18, 2004
Messages
33
Reaction score
0
City, State
Auburn Georgia
Year, Model & Trim Level
95 XLT
If I am going to have to change the intake and all the sensors I believe I am going to take the 96 engine back to the junk yard and exchange for a 95 with my same wiring harness.

The engine from the junk yard also has two wires going into the side of the oil pan which my original engine does not have.
 




Top