97 Explorer, Crank no Start after EGR work (faulty PCM??) | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

  • Explorer Forum license plate frames are available 2 for $12, or 4 for $17. For photos and more details CLICK HERE

97 Explorer, Crank no Start after EGR work (faulty PCM??)


New Member
January 31, 2011
Reaction score
Year, Model & Trim Level
'97 XLT, 5.0L
1997 Explorer XLT, 5.0L V8, 155k Miles

I've been having an intermittent check engine light with code P0401: Insufficient EGR Flow. Pulled into the garage and spent a bit of time poking around back by the firewall. Saw that the tube from the DPFE to Exhaust Manifold was cracked. Got some replacement tubing, but needed to take the DPFE off in order to get enough of a visual to actually put it on. Also had the throttle body off at one point trying to get eyes / hands on all of the tubing.

Then comes the exciting bit. Everything reconnected, went to start up the engine...crank no start. Several hours of troubleshooting later, I'm still stymied.

I started with the "Engine No Start Procedure" sticky thread that @2000StreetRod posted in the forum, and that led to the "PCM Power Procedure" thread.

Current Conclusions and Observations:
1. No CEL with Key On Engine Off. The CEL was working when I started this repair.
2. I have an OBD diagnostic scanner: doesn't detect the vehicle when plugged in (both Key On Engine Off, and Key Off). There is power to the port, the scanner starts searching as soon as I plug it in. The scanner was previously working in this vehicle, and still works in other vehicles.
3. Inertia fuel pump switch not tripped.
4. Pulled a spark plug wire and tried to get a spark to ground while cranking. Nothing.
5. Checked fuel pressure test port on the rail. No pressure.
6. Went through all the fuses. All test okay with test lamp.
7. On to relays. Placing a finger on the PCM relay, there is a definite click when the ignition is turned to the on position. The fuel pump relay does not click however. Swapped relays around, same result (i.e. putting the relay that was in fuel pump slot into the PCM slot makes that one click). Verified using test lamp.
8. Bypassed the fuel pump relay with a jumper wire. Was able to heard fuel pump turn on, and got gasoline at the fuel pressure test port.
9. Broke out wiring guide for the PCM harness connecter. Tested that all the ground pins were still connected with a voltimeter, as with battery power (memory) and power from PCM relay. All good.

As best as we can figure, *something* got bumped / dislodged while getting a ratchet and/or hands back by the EGR system or throttle body. It doesn't make sense that multiple systems in the car would have simultaneously failed while sitting in the garage for a couple hours. Currently thinking that the PCM is at fault, but am at a loss of further things to try.

Other than getting a replacement PCM, what else should I check?

Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!

Lacking any other comments, it sounds like you did a hell of a job diagnosing the issue. maybe disconnect the battery for 30 minutes and see if it resets? could also try a pcm from a salvage yard, but the 5.0L isn't as common as the V6....

I've got the 5.0l too, and love it. hope you get your's running and please let us all know what the result it. cheers!

check PCM connection

Did you disconnect the PCM connector and reinstall it? Check to make sure none of the pins are getting pushed back when it is installed. Also, check the PCM ground wire to the firewall.

Hi Yankee516 and 2000StreetRod--thanks for the replies.

Yep, have had the PCM disconnected for over an hour (overnight actually). No change.

PCM was not disconnected initially (while working with EGR system) before the No Start issues. We've had the wiring harness off and on with testing ground connections--all the pins look straight and shiny. Tested the PCM ground on the firewall with a voltimeter--checked out fine. Disconnected it an took a steel wire brush to it for good measure. For kicks, we ran a wire from there to the chasis--no change.

We also took apart the wiring harness connector between the PCM harness and the power distribution box, figuring that it was in the vicinity of the DPFE sensor and may have gotten bumped while working back there. All the pins there looked straight and new. About half of them appeared to be covered in some sort of white grease (presumably dielectric grease or similar), while the other half weren't. Can't see how it would make much difference, but we'll probably pick up a tube and coat all of them as a last resort.

Running out of ideas of anything to check before picking up a replacement PCM. Anyone have thoughts of how to potentially bench test one? Closest junkyard is about 2 hours away.

Wow... you are thorough! I really wish I had something else you could test, but at this point I think that it is the last course for you to check. I would never even think of disconnecting the battery before working on parts like this, but I think you've made me overly cautions if it is actually the PCM. Maybe you can order one from Rockauto.com or similar for shipment or a salvage yard that can ship. Rock auto has it listed for $106 with a $60 core charge, but I'm just not sure if they are coded to the VIN for the PATS system. I really don't think there is a way to bench test them since they are integrated circuit boards that are very complex.

Please let us all know the outcome, and maybe another member in the vicinity will offer to swap or give you a test unit.

TPS connector?

Did you reconnect the TPS connector after reinstalling the throttle body?

11th Hour Fix


Had already resigned myself to ordering a new PCM, but decided to give everything one final go over and basically disassemble and reassemble everything that we'd touched during this adventure. Came across this amateur hour beauty:

Managed to tighten down the lower left retaining bolt onto one of the wires to the TPS sensor. Soldered in a replacement section and it started right up. Whew.

Y'all were scary close thinking it was the TPS sensor or connector.

Thank you very much for the replies and help, Yankee516 and 2000StreetRod!

glad you found the problem

I'm glad that you found the source of the problem and thanks for posting it! You must have skipped the TPS test procedure step in the no start procedure.

The PCM is fairly reliable and hardy. It is frequently replaced unnecessarily.

i humbly bow to 2000streetrod! great catch! another great example of following the diagnostic steps to a 't'!

Thank you for your followup and the pic, i am sure it will be a big help to others on here! cheers for a job well done, be proud!