• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

99 Ranger 4.0L with the possibility of an internal coolant leak.

Fixing Ranger

New Member
Joined
January 14, 2010
Messages
4
Reaction score
0
City, State
South Berwick, Maine
Year, Model & Trim Level
99 Ranger
My Ranger has been sputtering around 40mph and 2000 rmp's, with rough starts in the morning. It has also been loosing small amounts of coolant and I have a lot of white smoke (steam) coming out of the tail pipe. I do not have any coolant leaking external. I have pressure tested the heads and all 6 cylinders held at 145psi for several minuets. I also pressure tested the coolant system and lost pressure very quickly. If the heads are holding pressure were is the coolant leaking?

Thanks,
 




slammed98z

Well-Known Member
Joined
January 20, 2009
Messages
176
Reaction score
1
City, State
Branson West, Missouri 65737
Year, Model & Trim Level
1996 Explorer 2DR
Sounds like a Headgasket, cracked head, or cracked block. Does the "white smoke" have the faint smell of antifreeze? Which 4.0 do you have? OHV or SOHC?
 




BrooklynBay

Moderator & long time member.
Staff member
Moderator
Elite Explorer
Joined
November 11, 2005
Messages
55,038
Reaction score
666
City, State
Brooklyn, NY
Year, Model & Trim Level
88 89 93 95 96 Aerostars




Fixing Ranger

New Member
Joined
January 14, 2010
Messages
4
Reaction score
0
City, State
South Berwick, Maine
Year, Model & Trim Level
99 Ranger
Thanks, this has been a learning experience. No coolant leak, just air from changing the water pump. Found some bad injectors and replaced them. But, now receiving codes for running rich on both banks?
 




Top