99 sport runs like garbage | Page 2 | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

99 sport runs like garbage

roscoe 0202

Well-Known Member
Joined
February 3, 2014
Messages
340
Reaction score
76
City, State
salt lake city utah
Year, Model & Trim Level
1999 explorer sport
check your gas cap if it leaks it will show too much air in evap circuit
roscoe
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.











Turdle

The Lowrider is a little higher
Staff member
Moderator
Elite Explorer
Joined
June 16, 2003
Messages
30,534
Reaction score
2,299
City, State
Humboldt, KS
Year, Model & Trim Level
2000 Mounty
Check all your fuses. There is one which protects the o2 sensors and evap valve stuff. It's worth a shot.
 






410Fortune

Truck Season!!
Staff member
Moderator
Joined
August 3, 2000
Messages
28,707
Reaction score
5,062
City, State
NORTH IDAHO, 7B
Year, Model & Trim Level
B2 "Slightly" Modified
Callsign
FOURTEN
I doubt its gas cap.......
He has a canister vent circuit malfunction code, not a too much air code.

A too much air code would tell you the canister vent is doing its job, working. In his case I am guessing he has a dead short in the sensor/wiring.
Rusty area + canister vent been mounted up there since 1998 = Circuit malfunction lol

OHV had 3ea 02 sensors, never 4?
I don't think unless it was a late 99-2000 thing, 2000 last year of OHV 4.0
R.I.P.
 






sport40

Member
Joined
April 26, 2017
Messages
30
Reaction score
4
Location
yelm,washington
Year, Model & Trim Level
2001 explorer sport
i have a 2001 sport and it had a miss i couldnt fix and it ended up being a valve in the head, miss on # 2 cylinder was code. replace the head, fixed problem, the sohc motors get carboned up bad if not driven hard a few times a yr.
 






stonerboys

Member
Joined
November 14, 2010
Messages
25
Reaction score
0
City, State
Pennsylvania
Year, Model & Trim Level
99 Sport
i have a 2001 sport and it had a miss i couldnt fix and it ended up being a valve in the head, miss on # 2 cylinder was code. replace the head, fixed problem, the sohc motors get carboned up bad if not driven hard a few times a yr.
Mine is an OHV motor. It was always started and ran for about 10 mins or so the whole duration of it sitting. It just started acting up when it got really cold up here in lake so I’m thinking it’s either a vacuum issue or it very well could be the intake gaskets. It isles erratically but if you rev it up or floor it while driving it seems to run fine. It’s missing under a load and at idle but wide open throttle it seems to run just fine. I’ll figure it out eventually
 






stonerboys

Member
Joined
November 14, 2010
Messages
25
Reaction score
0
City, State
Pennsylvania
Year, Model & Trim Level
99 Sport
i have a 2001 sport and it had a miss i couldnt fix and it ended up being a valve in the head, miss on # 2 cylinder was code. replace the head, fixed problem, the sohc motors get carboned up bad if not driven hard a few times a yr.
Mine is an OHV motor. It was always started and ran for about 10 mins or so the whole duration of it sitting. It just started acting up when it got really cold up here in Pa so I’m thinking it’s either a vacuum issue or it very well could be the intake gaskets. It idles erratically but if you rev it up or floor it while driving it seems to run fine. It’s missing under a load and at idle but wide open throttle it seems to run just fine. I’ll figure it out eventually
 






Top