• Register Today It's free! This box and some ads will disappear once registered!

ABS and Traction Control Lights

bobtylerjr

Elite Explorer
Joined
September 16, 2012
Messages
13
Reaction score
0
Year, Model & Trim Level
2007 Explorer Eddie Bauer
2007 Explorer, V6, 4.0 Liter, 4WD

ABS and Traction Control warning lights have been illuminating beginning after startup and at low speed (Just after vehicle begins to move) and remain on until vehicle is shut down. I used an Innova 3100j+ to obtain codes on the ABS system and received the following:

B1342 ECU Internal Fault

U1900 Communication BUS Fault

B1676 Battery Voltage Out of Range

U2023 Fault Received from External Node

Any thoughts, ideas, suggestions for a solution to this problem(s)?

Thank you!
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




bobtylerjr

Elite Explorer
Joined
September 16, 2012
Messages
13
Reaction score
0
Year, Model & Trim Level
2007 Explorer Eddie Bauer
Here’s and update...

Ran code reader again and only received a B1342 ECU Internal Fault

I also cycled the 4x4 and it DID engage and disengage.

Any thoughts would be greatly appreciated.

Thank you!
 




vipersinu2

Well-Known Member
Joined
March 10, 2008
Messages
643
Reaction score
13
City, State
The Big City of Orange City, Florida
Year, Model & Trim Level
2019 Navigator 450hp
2007 Explorer, V6, 4.0 Liter, 4WD

ABS and Traction Control warning lights have been illuminating beginning after startup and at low speed (Just after vehicle begins to move) and remain on until vehicle is shut down. I used an Innova 3100j+ to obtain codes on the ABS system and received the following:

B1342 ECU Internal Fault

U1900 Communication BUS Fault

B1676 Battery Voltage Out of Range

U2023 Fault Received from External Node

Any thoughts, ideas, suggestions for a solution to this problem(s)?

Thank you!
I think you have to get a new battery
 








vipersinu2

Well-Known Member
Joined
March 10, 2008
Messages
643
Reaction score
13
City, State
The Big City of Orange City, Florida
Year, Model & Trim Level
2019 Navigator 450hp
Did on my truck,
Wouldnt hurt to get battery tested
 








bobtylerjr

Elite Explorer
Joined
September 16, 2012
Messages
13
Reaction score
0
Year, Model & Trim Level
2007 Explorer Eddie Bauer
Had the battery tested. It has a bad cell. Replaced battery (under warranty). ABS and Traction Control Light still illuminating. Ran code reader again and received B1342 (with engine running because the warning lights turn off at shutdown and do not reiluminate until the vehicle begins to roll). Cleared all codes in memory via the code reader. Drove vehicle. Same result, ABS and Traction Control illuminate around 10mph

Other ideas?

Thank you
 




vipersinu2

Well-Known Member
Joined
March 10, 2008
Messages
643
Reaction score
13
City, State
The Big City of Orange City, Florida
Year, Model & Trim Level
2019 Navigator 450hp
How are the wheel bearings?
ohm out the wheel speed sensors make sure they are good, and check for voltage at sensors.
check to see if the exciter rings are still in place
 




bobtylerjr

Elite Explorer
Joined
September 16, 2012
Messages
13
Reaction score
0
Year, Model & Trim Level
2007 Explorer Eddie Bauer
Installed a new 40 amp fuse in slot number six for the ABS With new fuse installed ran rental code reader (Innova 3150 - couple models up from my Innova 3100j+) from Autozone, resulting in ABS light only and codes C1095 Pump Motor Circuit Failure (new code) and previous code B1342. Reinstalled old 40 amp fuse and all lights and codes went back to what I previously stated. So, slightly different codes and warning light illumination depending on the fuse. Not sure what that means other than maybe the pump has failed?

Trying to avoid having to pull wheels, etc
 




vipersinu2

Well-Known Member
Joined
March 10, 2008
Messages
643
Reaction score
13
City, State
The Big City of Orange City, Florida
Year, Model & Trim Level
2019 Navigator 450hp
I dont see any other option, but to pull the wheels, jack it up 1st and check for play in the wheel bearings.
 








MotorCityFats13

Explorer Addict
Joined
January 25, 2015
Messages
1,072
Reaction score
74
City, State
Flatrock MI
Year, Model & Trim Level
2007 Explorer XLT 4.0L
I had a single abs sensor fail and 4x4 would not engage ....trac control and abs lights were on and I didnt know what systems were turned off until i took off from a light roasting 1 rear tire so I knew all systems were disabled.... so I would guess its not a single wheel bearing or sensor
 




Top