• Register Today It's free! This box and some ads will disappear once registered!

abs light - hub

zpaperboyz

Active Member
Joined
November 23, 2009
Messages
80
Reaction score
0
City, State
Prince Rupert, BC,
Year, Model & Trim Level
2004 Ford Explorer 4x4
This is getting crazy, I replaced my driver front hub at about 95,000km then had a faulty hub the abs light immediately came on and the 4x4 light would come on and engage the 4x4. They replaced the hub assembly immediately, 22,000Km the abs light comes on again same issues, Napa replaces the hub even though its 2,000 km over the warranty but only 8 months. Now a month and a a half later the ABS light comes on again same issues. That makes the hub I'll replace it #5.
5 front left hubs in a 2004 explorer.

So here's my question - What else could be tripping this abs sensor and making the 4x4 kick in. the repair shops computer says its the front left abs sensor every time and the dealer says it all part of the one piece hub assembly.

I'm looking for ANY suggestions I'm going crazy. Holidays start Thursday next week and I doubt I'll have a working vehicle. Everything up here is remote and takes forever for parts.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




zpaperboyz

Active Member
Joined
November 23, 2009
Messages
80
Reaction score
0
City, State
Prince Rupert, BC,
Year, Model & Trim Level
2004 Ford Explorer 4x4
no suggestions eh?
 




miker104

Well-Known Member
Joined
November 25, 2009
Messages
216
Reaction score
2
City, State
N KY
Year, Model & Trim Level
'04 XLT
Have you tried using a Ford hub? Is the same place installing all the hubs?

Maybe there is an issue with the installation or part quality?
 




my pos mounty

Explorer Addict
Joined
September 15, 2009
Messages
1,812
Reaction score
1
City, State
Land of Corruption
Year, Model & Trim Level
06 F-350
Try a stock Ford bearing or buy a Timken bearing.
 








Vargas

Well-Known Member
Joined
December 3, 2004
Messages
295
Reaction score
0
City, State
Seattle, WA
Year, Model & Trim Level
'94 EB & two '00 XLT
From most likely to least likely

Inferior quality of part replaced with same inferior quality part.

Damage due to incorrect installation, and repeated by same person or shop each time.

Other damage on vehicle, such as broken/missing air front bodywork, fender liner, brake splash shield or ______ that is allowing/directing water to wash lubrication from bearing.
 




zpaperboyz

Active Member
Joined
November 23, 2009
Messages
80
Reaction score
0
City, State
Prince Rupert, BC,
Year, Model & Trim Level
2004 Ford Explorer 4x4
It has been the same shop and I'm going to guess same bearing as NAPA is their part supplier. But the bearing itself isn't going just the abs sensor that is part of the hub. I guess I'll try another supplier of the hubs on this 5th install and see what happens.

I've always thought Napa had good parts though.
 




Vargas

Well-Known Member
Joined
December 3, 2004
Messages
295
Reaction score
0
City, State
Seattle, WA
Year, Model & Trim Level
'94 EB & two '00 XLT
The ABS sensor is not part of the hub. It mounts to the hub. The ABS error light (those codes that point to bad front ABS sensors) is a common symptom of a failing/failed hub/bearing assembly. When a hub fails, the ABS sensor does not need to be replaced, just removed and reinstalled on the new hub.
 




lucygirl

New Member
Joined
April 17, 2012
Messages
3
Reaction score
0
City, State
Guyton,Georgia
Year, Model & Trim Level
2007 ford sport trax
I thought that a $237.00 part would be good?
 




vipersinu2

Well-Known Member
Joined
March 10, 2008
Messages
643
Reaction score
13
City, State
The Big City of Orange City, Florida
Year, Model & Trim Level
2019 Navigator 450hp
for the 1st few presses of the brake pedal in the cool morning, the anti lock is kicking in, after truck warms up brakes are ok, also the abs light comes on after the abs starts acting up, when truck is off and restarted the light is off. is there any tell tail signs to look for, I will check for play in the wheel bearing tomorrow,
 




matt0248

Well-Known Member
Joined
July 12, 2010
Messages
761
Reaction score
2
City, State
Chicago
Year, Model & Trim Level
02 XLT V8
for the 1st few presses of the brake pedal in the cool morning, the anti lock is kicking in, after truck warms up brakes are ok, also the abs light comes on after the abs starts acting up, when truck is off and restarted the light is off. is there any tell tail signs to look for, I will check for play in the wheel bearing tomorrow,

you may not feel play in the bearing but it could still be bad. Is the bearing loud? when the ABS light is on what code is present. This will lead you in the right direction.
 




vipersinu2

Well-Known Member
Joined
March 10, 2008
Messages
643
Reaction score
13
City, State
The Big City of Orange City, Florida
Year, Model & Trim Level
2019 Navigator 450hp
the abs light went out today, will the code still show up or does the abs light need to be on?
 




Mr_Fruffles

Elite Explorer
Joined
November 15, 2016
Messages
80
Reaction score
6
Location
Denver
City, State
Denver, CO from Tinley Park, IL
Year, Model & Trim Level
2015 Ford Explorer XLT
Callsign
Mr_Fruffles
What came of all of this? sounds familiar for me lol
 




Top