AC compressor is giving me problems | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

AC compressor is giving me problems

Andy96XLT

Well-Known Member
Joined
October 5, 2007
Messages
574
Reaction score
3
City, State
Branchburg NJ, Bethlehem PA
Year, Model & Trim Level
96 XLT
Hey everyone,
I went to recharge my AC yesterday and notice that the compressor clutch was cycling on and off while the AC was at max cool, (makes sense, the cycling should mean I needed to recharge.) I then tried to recharge the AC and the clutch wouldn't cycle on at all. I replaced the compressor because I randomly had another one lying around thinking the clutch went bad but it still does not cycle on. Same problem however though. I checked just putting power directly to the clutch with the car running however and that did engage the clutch. I checked the AC fuse and it is good... I am thinking now maybe the switch went bad even though it worked before I charged the system? Any ideas what could be the problem?? I was thinking if its really tedious im just going to run a remote toggle switch to turn the AC on and off but I am hoping this is something stupid. Thanks.
-Andrew
 






Andy96XLT

Well-Known Member
Joined
October 5, 2007
Messages
574
Reaction score
3
City, State
Branchburg NJ, Bethlehem PA
Year, Model & Trim Level
96 XLT
anyone... anyone?
 






Andy96XLT

Well-Known Member
Joined
October 5, 2007
Messages
574
Reaction score
3
City, State
Branchburg NJ, Bethlehem PA
Year, Model & Trim Level
96 XLT
nevermind, replaced a relay and all seems good now... go figure its always something simple...
 






Top