• Register Today It's free! This box and some ads will disappear once registered!

Added Navigation to 2008 Explorer limited, time and voice button issue


Nerds 2 You

New Member
Joined
July 10, 2020
Messages
5
Reaction score
0
City, State
Edmonton
Year, Model & Trim Level
2008 Explorer Limited
Hi All, I Have a 2008 Explorer limited that did not come with factory navigation. I found a navigation unit at a local auto wrecker for $125 Cdn and bought it as the donor vehicle was also a 2008 Limited, had rear seat entertainment as mine does, had Sync etc and was mostly identical to mine.

I installed the head unit and almost everything works correctly, the seek and volume from the steering wheel, rear entertainment system shows on the nav screen and works, I can set pre-sets for the radio, everything else I tried works except for two things.

I cannot set the time or date, I tried but the buttons to adjust time do nothing.I believe this may be because I do not have the GPS antenna yet, can anyone confirm that the factory navigation radio automatically gets time and date from GPS?

The Voice button on the steering wheel is no longer working, the donor vehicle had Sync so I figured it should work. I still get voice prompts from the system when doing certain things like connecting a new phone and some other functions that automatically trigger sync response. Anyone know if there is a way to resolve this? I tried searching for a list of Forscan mods but have not been able to find anything yet.

Any help or suggestions would be greatly appreciated.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




Nerds 2 You

New Member
Joined
July 10, 2020
Messages
5
Reaction score
0
City, State
Edmonton
Year, Model & Trim Level
2008 Explorer Limited
If Anyone has 2008 Explorer with factory navigation, rear seat entertainment and Sync I may be able to figure out the programming if you can provide me with the as built data for your Explorer and I can compare it to mine and may be able to figure out how to re-program using Forscan.

If you go to https://www.motorcraftservice.com/AsBuilt ( you may have to visit twice, first to enter your location and language, then click the link again to get to the proper page) enter your VIN and either private message me your as built data or post it here, likely only need the ACM (Audio Control Module) information but not 100% sure.
 




Nerds 2 You

New Member
Joined
July 10, 2020
Messages
5
Reaction score
0
City, State
Edmonton
Year, Model & Trim Level
2008 Explorer Limited
I figured out the date and time, I went into the hidden service menu and was able to manually set the GPS time, I have a GPS antenna on the way as well so that should take care of the problem permanently.

I still have not figured out why my voice button won't work, will have to dig through the service menu items to see if there is anything in there that can be used to activate or change a setting
 




JeffreyM

New Member
Joined
December 16, 2019
Messages
6
Reaction score
0
City, State
Florida
Year, Model & Trim Level
2008 Explorer Limited 4.6
I figured out the date and time, I went into the hidden service menu and was able to manually set the GPS time, I have a GPS antenna on the way as well so that should take care of the problem permanently.

I still have not figured out why my voice button won't work, will have to dig through the service menu items to see if there is anything in there that can be used to activate or change a setting
I too have an 08 that I am trying to add navigation to. If your vehicle had Sync without nav, you will also have an 'OK' button next to the sync button. I believe the ones that came with Nav do not have the OK button. I guessing there may be a different resistance value for the button that may be an issue. I've also seen a post (from many years ago) where someone said to reroute the audio from the microphone in the mirror, directly to the ACM instead of the APIM (sync module).
Interested to know if you get this solved
 




Nerds 2 You

New Member
Joined
July 10, 2020
Messages
5
Reaction score
0
City, State
Edmonton
Year, Model & Trim Level
2008 Explorer Limited
I too have an 08 that I am trying to add navigation to. If your vehicle had Sync without nav, you will also have an 'OK' button next to the sync button. I believe the ones that came with Nav do not have the OK button. I guessing there may be a different resistance value for the button that may be an issue. I've also seen a post (from many years ago) where someone said to reroute the audio from the microphone in the mirror, directly to the ACM instead of the APIM (sync module).
Interested to know if you get this solved

Thanks! , I took a closer look at the different steering wheels and now see that the Navigation equipped came with a different button configuration ( The iDatalink Maestro website shows all the different options for steering wheel buttons iDatalink - Maestro - Maestro RR) I am going to contact the wrecking yard that I got the radio from and see if I can get the button cluster from them and change it out. I'll have to search this forum and other places to see if anyone has successfully done this yet and if the connector is the same before I commit to purchase.


My GPS antenna arrived on Friday and it did indeed resolve the issue with being able to set the time normally (without having to go into the service menu) I need to play around with placement of the antenna though because I am only getting a lock on 2 or 3 satellites sometimes, even when on the highway. I did successfully download and burn my own copy of the 2015 map data and it works properly.
 




nosdakota

New Member
Joined
December 20, 2017
Messages
2
Reaction score
0
City, State
Union, KY
Year, Model & Trim Level
2007 Exploder
Thanks! , I took a closer look at the different steering wheels and now see that the Navigation equipped came with a different button configuration ( The iDatalink Maestro website shows all the different options for steering wheel buttons iDatalink - Maestro - Maestro RR) I am going to contact the wrecking yard that I got the radio from and see if I can get the button cluster from them and change it out. I'll have to search this forum and other places to see if anyone has successfully done this yet and if the connector is the same before I commit to purchase.


My GPS antenna arrived on Friday and it did indeed resolve the issue with being able to set the time normally (without having to go into the service menu) I need to play around with placement of the antenna though because I am only getting a lock on 2 or 3 satellites sometimes, even when on the highway. I did successfully download and burn my own copy of the 2015 map data and it works properly.
Where were you able to find a downloadable version of the map data? I'm only finding the ones on ebay. Not that I mind paying a couple bucks, but I'm always up for instant gratification.
Thanks
 




94Eddie

Elite Explorer
Joined
September 18, 2003
Messages
873
Reaction score
193
Year, Model & Trim Level
2010 Mountaineer Premier
Where were you able to find a downloadable version of the map data? I'm only finding the ones on ebay. Not that I mind paying a couple bucks, but I'm always up for instant gratification.
Thanks
I would like to know this also.
 




JeffreyM

New Member
Joined
December 16, 2019
Messages
6
Reaction score
0
City, State
Florida
Year, Model & Trim Level
2008 Explorer Limited 4.6
Thanks! , I took a closer look at the different steering wheels and now see that the Navigation equipped came with a different button configuration ( The iDatalink Maestro website shows all the different options for steering wheel buttons iDatalink - Maestro - Maestro RR) I am going to contact the wrecking yard that I got the radio from and see if I can get the button cluster from them and change it out. I'll have to search this forum and other places to see if anyone has successfully done this yet and if the connector is the same before I commit to purchase.


My GPS antenna arrived on Friday and it did indeed resolve the issue with being able to set the time normally (without having to go into the service menu) I need to play around with placement of the antenna though because I am only getting a lock on 2 or 3 satellites sometimes, even when on the highway. I did successfully download and burn my own copy of the 2015 map data and it works properly.
Wondering if you ever got this resolved. I have tried again installing my Nav unit, this time I changed the steering wheel switch out with the correct one for the Nav unit, the one without the "OK" button. Steering wheel buttons do not work correctly. Media, and Scan up button both change the media source. Volume up button increases volume and changes media. Phone and Voice button do nothing. My nav unit came out of a Taurus X. I happen to also have one of these cars that came equipped w/ nav and sync. I swapped radios and it works perfectly in that car.
I'm really getting frustrated at this point. My original intent was to add factory satellite radio, but I still have no audio from that.
Any help or suggestions welcome.
 




Top