Another bad PS pump?!?! | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Another bad PS pump?!?!

shadowless127

Explorer Addict
Joined
December 13, 2007
Messages
2,714
Reaction score
10
City, State
Long Island, NY
Year, Model & Trim Level
'01 EB AWD 5.0
Power steering is acting up again the same way it was when my PS pump was dying back in November. I've since had the pump replaced (just the pump, same tank and same pulley) and it's seemed to have returned to the same behavior BUT it only does it like half to 3/4 of the time. Fluid level is fine. The pump was a reman from Advance Auto.

Could a bad tank or bad pulley cause this? I'm going to be really pissed if I have to replace the pump again. I'm starting to feel like the X is becoming a massive money pit the past 6 months and it's starting to get to me.
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




1996BLKBauer

Explorer Addict
Joined
June 24, 2011
Messages
1,688
Reaction score
10
City, State
McHenry, IL
Year, Model & Trim Level
1996 Eddie Bauer AWD V8
Since the pump, and rack need to work together to work at all, a failing rack could be causing the pump to fail. One of the kids in my class replaced his power steering pump on his Ranger, and less then a week later it died again, it turns out something inside the rack was not allowing the fluid to pass through easily, and it ruined the pump, he replaced the rack, and pump(again), and it was all good.
 
<



ssobel80

Member
Joined
August 30, 2012
Messages
49
Reaction score
0
City, State
New Jersey
Year, Model & Trim Level
2000 Ford Explorer XLS
+1 on the rack. I blew 3 ps pumps before I figured that out!! Replaced the rack and everyting works great! Except for the noisy power steering pump. Really is starting to become annoying!
 
<



shadowless127

Explorer Addict
Joined
December 13, 2007
Messages
2,714
Reaction score
10
City, State
Long Island, NY
Year, Model & Trim Level
'01 EB AWD 5.0
Awesome -_-

How do you guys feel about used steering racks?
 
<



Dave 1955

Well-Known Member
Joined
March 12, 2013
Messages
373
Reaction score
2
City, State
Brockport,NY.
Year, Model & Trim Level
2001 Explorer
Did you by any chance move the steering back and forth with the motor off..as in doing a brake job?

First time I did that on my old 95 the pump was really noisy and the steering was strange.
Thought my rack was toast but found out all I had to do was move it lock to lock a bunch of times and it was fine..must have been air in the system i guess.
 
<



obie

Well-Known Member
Joined
June 13, 2012
Messages
902
Reaction score
9
City, State
Northwest Indiana
Year, Model & Trim Level
2003 Sport Trac 4x4
Awesome -_-

How do you guys feel about used steering racks?

Personally, I wouldn't recommend it. Though, a Ford one is about 450, and even a quality Cardone reman is 240 (90 after core, through RockAuto). If you can find one from a low mileage Ex, and install an inline filter, you could probably keep using it for a good long while. Valvoline MaxLife PS fluid helps too.
 
<



1996BLKBauer

Explorer Addict
Joined
June 24, 2011
Messages
1,688
Reaction score
10
City, State
McHenry, IL
Year, Model & Trim Level
1996 Eddie Bauer AWD V8
Awesome -_-

How do you guys feel about used steering racks?

On some cars it's alright, but on our Explorers, it stinks to change out the rack, I would just get a new one, and do it once.
 
<



shadowless127

Explorer Addict
Joined
December 13, 2007
Messages
2,714
Reaction score
10
City, State
Long Island, NY
Year, Model & Trim Level
'01 EB AWD 5.0
Did you by any chance move the steering back and forth with the motor off..as in doing a brake job?

First time I did that on my old 95 the pump was really noisy and the steering was strange.
Thought my rack was toast but found out all I had to do was move it lock to lock a bunch of times and it was fine..must have been air in the system i guess.

No I didn't try that. The strange thing is it can be fine and then all of a sudden while i'm driving it just starts acting up. And it whines like a bitch sometimes at idle and as im accelerating even if I have the wheel straight and am driving straight.
 
<



drifte

Member
Joined
May 3, 2012
Messages
27
Reaction score
0
City, State
iowa
Year, Model & Trim Level
00' mountaineer v8 awd
Im having issues myself, for the last year my pump has been whining loudly. Finally replaced it last night, and now while trying to bleed it with the truck running, wheels in the air and turning the wheel, the steering wheel will randomly start shaking very violently until I shut off the engine. If this needs a rack, Im just going to scrap it!
 
<



Top