• Register Today It's free! This box and some ads will disappear once registered!

Apten chip broken

BeauJ

Moderator Emeritus
Joined
January 23, 2002
Messages
4,596
Reaction score
4
Well, after over a month, I finally got my Apten chip back. Put it in Friday afternoon, cleaned all the connections, let it run for 20 mins. Drove it around, didn't feel a difference at all. So I took the chip out to make sure it was making good contact and what do I see??? I guess it got broken being shipped back, because in the little bag it was in there where little plastic chips.



I'm pretty much screwed on this chip, aren't I? Anyway it could still work?
 

Attachments

  • chip.jpg
    chip.jpg
    5.8 KB · Views: 114


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




spindlecone

Explorer Addict
Joined
April 30, 2004
Messages
4,836
Reaction score
0
City, State
San Jose, Calif
Year, Model & Trim Level
2003 sport trac
Bummer, looks bad dude
 




Billy177

Explorer Addict
Joined
July 10, 2003
Messages
1,898
Reaction score
0
City, State
Redding CT
Year, Model & Trim Level
99 Explorer XLT SOHC 4x4
ya my old one was kinda broken too. car wouldent start when it was below freezing
 




BeauJ

Moderator Emeritus
Joined
January 23, 2002
Messages
4,596
Reaction score
4
It's gotten cooler in GA, so I can't really tell the performance because my S/C loves cold air. But I asked for the firmest shifts possible, and the shifts still suck.

Billy, was your chip that bad and did it still work?
 




Billy177

Explorer Addict
Joined
July 10, 2003
Messages
1,898
Reaction score
0
City, State
Redding CT
Year, Model & Trim Level
99 Explorer XLT SOHC 4x4
no not that bad but i e-mailed brian and he sent me a new one fedex and i got it the next day. unfortuniatly i do not know of their customer service is still as good
 




Top