• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

Audio keeps switching from CD-AM/FM-Clock-CD...repeat

Bdunc

New Member
Joined
June 21, 2014
Messages
1
Reaction score
0
Year, Model & Trim Level
1998 Explorer
So here is my problem:

I purchased a used 1998 explorer (in great condition:thumbsup: ) and the audio has recently been alternating between the CD and the AM/FM radio.

-There is no CD in the disc slot (I checked)
-Pressing the CD button displays "No Disc"
-Pressing the "eject" button and holding it in fixes the problem and it stays on the AM/FM setting without switching to CD. As soon as I let it go it starts rotating through the settings again.
-Pressing and holding any other button does not fix the problem


The audio system is only AM/FM with a CD player. I'm not sure what audio system it is. But it is a stock radio.

Does anyone have an ideas if this can be easily fixed or do I have to take it somewhere to get looked at?

Thanks!
 
Join the Elite Explorers for $20.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.


Scorpion8

Active Member
Joined
February 13, 2014
Messages
309
Reaction score
18
Location
SE-AK
City, State
SouthEast Alaska
Year, Model & Trim Level
2006 Explorer XLT
You might try re-setting the unit by pulling it out and disconnecting all of the cables. Wait a few minutes before plugging it back in. That "reset" trick always does it in my Dodge Ram OEM radio from the same era.
 

DjDom

Moderator Emeritus
Joined
September 11, 2011
Messages
2,621
Reaction score
3
City, State
Toronto, Ontario
Year, Model & Trim Level
97 XL(imited)
Wow, never heard of anything like this on the stock radios.

Have you tried putting a CD in and seeing what happens?
 

intelisevil

Elite Explorer
Joined
May 11, 2006
Messages
324
Reaction score
2
City, State
Sandy, OR
Year, Model & Trim Level
'00XLT-SOHC,'99Mounty-5.0
I don't have a fix either but I have the same problem in my '00 XLT.

In my case I have a Radio/Tape/CD unit. It will randomly start rotating through just like you described but add Tape into the rotation. If my unit is OFF, it will randomly turn itself ON. If mine starts to act up I just turn the volume down and ignore it.

It's hard to believe that only two of the millions of these units that Ford made have this symptom . . .

I'm hoping someone will come up with an answer other than to buy a new radio. I really like the features of the one I have.

Dan
 

Scorpion8

Active Member
Joined
February 13, 2014
Messages
309
Reaction score
18
Location
SE-AK
City, State
SouthEast Alaska
Year, Model & Trim Level
2006 Explorer XLT
Get a can of compressed air like you use to clean your computer keyboard and blow out both the CD slot and/or cassette slot. There could be dirt or debris in there that is tripping a leaf microswitch. If that is unsuccessful, pull it out and reset it by removing all the power cables. Also try cleaning the switches with a good cleaner electronic like DeOxit.
 

LaToya Evans

New Member
Joined
March 23, 2018
Messages
1
Reaction score
0
City, State
Palmdale, California
Year, Model & Trim Level
1998 Explorer
I have a 1998 Explorer and I have the same exact problem. radio...CD...radio...CD. It's like a ghost in the machine and its driving me nuts. Ill first try the duster in a can and then reset process. Will do a follow-up.
 

MandyGwen

New Member
Joined
March 16, 2020
Messages
1
Reaction score
0
City, State
McKinney, Texas
Year, Model & Trim Level
2013 Ford Explorer
I have a 1998 Explorer and I have the same exact problem. radio...CD...radio...CD. It's like a ghost in the machine and its driving me nuts. Ill first try the duster in a can and then reset process. Will do a follow-up.
Any updates? My 2013 Explorer does this and its driving me crazy. It’s possessed.
 
Top