• Register Today It's free! This box and some ads will disappear once registered!

Automatic climate control

mjkempton

New Member
Joined
July 20, 2010
Messages
1
Reaction score
0
City, State
Minneapolis, Minnesota
Year, Model & Trim Level
1998 Eddie Baure
Hi everyone, I have a 98 eddie baure with automatic climate control. About 3 weeks ago I noticed that the blower motor would only work on high. When it reaches the set temp it shuts off completly until the temp. rises then it will come back on until it gets back to the set temp. In the past it would run at the lower speeds to maintain the temp. Any thoughts anyone???
 




ssteiger

New Member
Joined
July 17, 2010
Messages
7
Reaction score
0
City, State
north carolina
Year, Model & Trim Level
2003 Eddie Bauer
I am not positive on your model but on some older models there is one fuse for the high speed and one fuse for the 3 lower speeds. I would start by checking the fuses.
 




tv4fish

Active Member
Joined
October 16, 2007
Messages
97
Reaction score
0
City, State
Minnesota
Year, Model & Trim Level
2007 EB V8 & 2002 EB V6
Blower motor

mj: I'm guessing it is NOT a fuse, but rather your "Blower motor controller" - I have an '07 EB with the automatic heater/AC controls. I could not adjust the blower speed at all - it would be on high all the time. Even pushing the "off" button did not do anything. There is a good thread on this forum about this "typical" problem. I replaced the controller (easy job, but the part was about $60) -- problem fixed. :)
http://www.explorerforum.com/forums/showthread.php?t=272849&highlight=blower+motor+controller
 




Top