blinkers/hazards work only when tilt steering is upright | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

blinkers/hazards work only when tilt steering is upright

thePig

New Member
Joined
October 6, 2004
Messages
5
Reaction score
0
City, State
CNY
Year, Model & Trim Level
98 XLT
I'm a new member and was wondering if this has happened to anyone here, but basically what is says, I can only use my directional or hazards while the tilt steering is all the way up, who drives like that? Anyway I'm gonna go start tearing it apart, hopefully someone chimes in soon with a quick and easy fix :confused:
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Sounds like a loose connection in the column...probally the connector to the turn stalk or the hazard switch...
 






SportlineXLT said:
Sounds like a loose connection in the column...probally the connector to the turn stalk or the hazard switch...

Ford calls it the multifunction switch. Can be the connection or the switch itself. The switch is a relatively frequent failure item in my experience.
 






Had this happen to me. The clips on one of the connetors broke causing it not to stay connected. I guess it broke from tilting the steering wheel up and down alot. I just used some tape to secure it in place.
 






It was a broken clip on the connector. Had to remove 3 screws under the column and glued & taped the plug back. Quick and easy fix, took 20 minutes. Thanks for the help! :thumbsup: :D
 






Back
Top