Blueka's "Pickle" Registry.... | Page 17 | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Blueka's "Pickle" Registry....

Since 2005 when I bought "Betty", my UK Explorer, I've wanted a sport...

well, now that I live in Canada, the chance has presented itself for me to get one...

This one.... it's a 99 sport, 4.0 SOHC... it's a total write off for the moment... but when I saw the advert on Kijiji I couldn't say no. It needed some love and I wanted a project to get stuck into, so I did my research and found out how much parts are gonna cost me etc etc.

So. I present.. Pickle.. (cos it's green and in a right mess)



Si
Explorer vin x.jpg
Explorer vin E 2.jpg
Explorer vin E.jpg
Explorer vin E 1.jpg
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





300820111718.jpg


That's the best picture I could get for you Tim,

It's 5" from the damper outside damper mount to the frame for the gas tank... that narrows down to 4" and the flange for the U-joint is roughly 1" away from the gas tank frame... hope that helps some....


Si
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





yes it dose simon. thank you. i can do some comparisons now with evil stock, and a 97 4 door that i have here at the moment and see just how hard, if possible a 4406 swap will be.
 












very true, however, i think they are shorter mid way where the gas tank is. if that makes any sense to anyone
 












Looks great, came along way!!
 






Thanks....

Tonight, I installed my new bumper with reverse park sensors... but there's an issue with it, so I'll get pictures tomorrow and see if I can get the sensors to work...


Si
 






Well, still can't get the sensors to work... but it doesn't look too bad for being painted with rattle cans...

newbackbumper.jpg




Si
 






Here's a little video of me doing some mild wheeling - due to a bad camera angle, this hill looks pretty lame... it's actually pretty steep

th_2011085.jpg



Si
 






I changed my mind and bought some "V8" badges off ebay, $5 shipped.... sanded them down and took the chrome off them, then used the leftover paint I had to paint the rear bumper...

They're slightly wonky.. but it's ok...

220920111745.jpg

220920111746.jpg

220920111747.jpg




Si
 






You need to dewonky the passenger side. Use a piece of tape below the emblem as a guide.
 






I know... I will eventually, I've gotta order a new battery and I've already ordered a new battery negative cable. It's killing batteries every couple of weeks


Si
 












nope.. still idles at a grand... also found out today that if I stomp on the brakes hard that it comes out of gear.. haha... I've got some updates coming soon.. .been busy!!


Si
 






check the hose's coming off your EGR Pressure Feedback Sensor going to the manifold. i noticed when i was taking evils 5L apart, one of the hoses had rubbed threw in one spot, and it to had a high idle. hey, worth a shot, right?
had to look threw your thread again for two reasons. one, for a refresher on your swap, and two, just how far you have come, with the little cash that you have had with pickle. congrats once again.
 












Do you have pictures Tim? funny you should mention the EGR, I got a code the other day from the EGR... insufficient or something..

Anyway, if you can let me know what I'm looking for, I'll have a look when I put my winter rubber on...


Si
 






the ones that i highlighted in red. IIR, one of them rubbed threw on either the fuel rail or harness. run your finger down both of them, or even unbolt the sensor and take a look at the lines.

DSC00629_Medium_.jpg


let me know if that solves the problem, that way i know that i have also found the high idle in mine (cause, well i havent put the motor in yet, waiting on TMH :D).
 









Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Well... I know it's been a while... and I've had thoughts of selling her... they're now gone, so everyone can relax...

I bought a new stereo for her... Same as the one in Betty, I love this set up, I love everything about it, so I got another one...

Sony XAV-7W head unit, XM ready, if that's what you're into...

IMAG0075-1.jpg

IMAG0074.jpg


I'm just waiting on my parents sending me over the dvd changer from Betty, so I can have some film watching capability!!

I also fitted the winter rubber.. not sure I like them... but whatever....
IMAG0073.jpg



Si
 






Back
Top