Brake/Flasher lights not working | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Brake/Flasher lights not working

phegler

Member
Joined
February 8, 2007
Messages
10
Reaction score
0
City, State
nc
Year, Model & Trim Level
1991
Hopefully someone here can help before we put any more money into this.

My daughter just purchased a 91 explorer 4wd. She loves it but we have to do a little work to it.

The brake lights/flashers are not working. The turn signals work and the tail lights come on when we turn on the head lights.

We checked the fuses. We changed the flasher fuse, we put in new bulbs and a new brake light switch.

She is paying for the repairs and is only 16 so before going any further we really would like to see if anyone has any ideas on what else to check.

Thanks for your help in advance.
 
<



phegler

Member
Joined
February 8, 2007
Messages
10
Reaction score
0
City, State
nc
Year, Model & Trim Level
1991
Ok I thought I would update. It has been awhile I know but thought if someone else runs into this that this might help. We literally tore that truck apart trying to figure out what was wrong. It was not the Mutifunction switch. Under the hood there are fuses (passanger side against the firewall). There is a #40 fuse there that we found blown. We kept changing it and it kept blowing. So one day we think we have it fixed and my daughter calls us and says that it blew again and there was smoke coming from the steering wheel. She is freaking out sitting at the gas pumps. Long story short we tore the front panels apart inside and found nothing that looked like it shorted. We did smell something and it ended up being the lighter had a loose wire that ended up shorting it out and causing all the turmoil. So if this happens and you find you keep blowing this fuse.....check your lighter.
 
<



Top