brake light | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

brake light

monkeypothrower

Well-Known Member
Joined
January 17, 2005
Messages
206
Reaction score
0
City, State
Charleston SC
Year, Model & Trim Level
1993 Xlt
Alright, so my buddy told me i had a brake light out. So i go and buy the bulb. When i put the new bulb in, it still doesnt work. BUt when i turn the headlights on, it does. So i switched the bulbs from one to the other brake light and same thing. Only the right side one doesnt work. Could it be the brake light switch, if only one is out? Thanks -TJ
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




Blee1099

Evil Asian
Moderator Emeritus
EF Vendor
Joined
March 3, 2002
Messages
13,992
Reaction score
6
City, State
Elkridge, MD
Year, Model & Trim Level
91
Check your fuses.
 
<



monkeypothrower

Well-Known Member
Joined
January 17, 2005
Messages
206
Reaction score
0
City, State
Charleston SC
Year, Model & Trim Level
1993 Xlt
its been checked. THis is strange, only one light now working. -TJ (also thanks for moving, sorry for the mistake.was just in a rush.)
 
<



Maniak

Moderator-Stock 91-94
Elite Explorer
Moderator Emeritus
Joined
February 9, 1999
Messages
12,084
Reaction score
122
City, State
Vail, Arizona
Year, Model & Trim Level
1992 XLT 4x4
Won't be a fuse or the switch.. I tuses the same fuse for both sides.. and the same for the switch..

Most likely you have a broken wire or dirty connection... Its time to start tracing the wire.. Follow the brake light wire (bad one) down to where you start to have power.. then fix the break (or dirty connector).

~Mark
 
<



monkeypothrower

Well-Known Member
Joined
January 17, 2005
Messages
206
Reaction score
0
City, State
Charleston SC
Year, Model & Trim Level
1993 Xlt
i fixed it. My next situation was finding the dirty connection. After about 5 minutes doodling around there was dirt in the connecters, not allowing one side of the connection to close all the way. Who knows how it got in there, but its done now, and thanks for you who tried to help. -TJ
 
<



Top