Brake Rotors | Page 2 | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Brake Rotors

OK now I feel kinda stupid. They sent 2 boxes, each with 2 rotors... I only opened the top boxes in each box.

I just went out and opened the bottom too and bam.. front rotors!

One of them is f'd up though. rust in the vents, yellowish color... and I just received them a couple days ago! Either way, the pads they sent wont fit and I wouldn't have installed the rotors with old (stock) pads.

I still have a question as to why the rear ones are diff.

I'll post pics in a min
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





They are different then your stock ones.? They are probably the wrong ones then. They need to have the same dimensions. Mine looked the same except for the slot and holes.

Definitely put new pads with the rotors and seat them properly.
 






Here are the 4 rotors. You can't tell much in this pic because of the camera flash & lighting, but the top left one is very yellow.

top 2 are the fronts...
 






and if I would attach the pic, they would look like this:

rotors3.jpg
 






here are the 2 rear rotors... one has a lip around the edge and the other doesn't. I haven't looked at my stock ones yet, but are yours like this?

rotor_nolip.jpg


rotor_withlip.jpg
 






yeah one looks different than the other. Probably machined at different times. get them to send you a set that looks the same.
They are supposed to be zinc coated. take some close up pics and have them send you new ones. YOU payed your money and it needs to be "as advertised"

if they left front has rust maybe they didn't zinc coat it.

Don't think mine had a lip on it. let me search for a pic.They need to be the same. The lip probably wont bother anything if the overall height is the same,but It would bother me to look at it.

Yep rears had that lip. They don't touch the wheel though.
 






It might be zinc coated, but it looks like it sat a while before it was...

this is the "yellow" one...

yellow1.jpg


yellow2.jpg


yellow3.jpg


:thumbdwn: :thumbdwn:
 






While I'm at it... here are the pads that don't fit.

pads.jpg


:mad:
 






I don't get it..whats wrong with these guys...

make them send you new ones right away .
don't keep crap. that blows man...

That looks like it sat for some time after machining. and it should not rust in those no contact areas.

who would send that out. What are they blind. I mean that is ridiculous.
 






I can't remember if my rears had a lip, but they at least should be the same.

yes had lip,but doesn't touch the wheel
 






Yeah, I'll be calling them when they open.

No way I'm going to put those on my truck!


I saw in the other thread that you said you have some stripped lug bolts on yours? I just replaced the front hubs in mine, fairly easy job! I paid $245 shipped for both front hub/bearings. I needed one, but went ahead and did both. You can buy the bolts at autozone and press (or hammer) them in yourself it thats all you want to do.

The front hubs are easy to take off. Remove the brakes and it's just 3 bolts (and a little bit of adhesive) that holds them on!
 






here are my latest set with tooling marks on the rotor.
I am gonna call them.and it will be round 5 for whatever they send next.
Thats 8 rotors sent for the front so far.
 

Attachments

  • 0005.jpg
    0005.jpg
    60.4 KB · Views: 202
  • 0004.jpg
    0004.jpg
    63.1 KB · Views: 206
  • 0002.jpg
    0002.jpg
    50.7 KB · Views: 199






Yeah, I'll be calling them when they open.

No way I'm going to put those on my truck!


I saw in the other thread that you said you have some stripped lug bolts on yours? I just replaced the front hubs in mine, fairly easy job! I paid $245 shipped for both front hub/bearings. I needed one, but went ahead and did both. You can buy the bolts at autozone and press (or hammer) them in yourself it thats all you want to do.

The front hubs are easy to take off. Remove the brakes and it's just 3 bolts (and a little bit of adhesive) that holds them on!

thanks I wanted to change out them studs. what kind of adhesive you use for the hubs.
maybe I will just do the studs for now. i was wondering if it would be crazy to try and change them all...lol. Maybe I will just do the 2 bad ones. I filed them pretty good and finally got the lugs back on properly.


Good luck with the rotors. I will call them too. I was hoping the rep I last spoke to would get back to me, but NO.
 






I didn't use any, ford uses some kinda flexable black stuff. RTV or something?

I just noticed you have a 4x4... you'll also need to take off the big nut and use a puller.
 






I didn't use any, ford uses some kinda flexable black stuff. RTV or something?

I just noticed you have a 4x4... you'll also need to take off the big nut and use a puller.



Yeah I know...lol I was not looking forward to it.

I am just gonna save the hassle and replace the bolts. I will do it when i get my new rotors after these get replace for the 5th time...lol
 






I called today...getting replacements sent.

Whats your news?
 






I've been so busy I haven't had a chance to call yet. I did send an email, so when I do call (probably Monday), I'll be able to say "I'm calling because I never got a response to my emails".
 






They order them from overseas then machine them on site. I asked and they told me. The zinc plating is sent out.

BUT I definitely believe that could happen...lol

I ordered from them because they have a good rating(when I ordered from them) and few guys here are happy withe R1's products.

Maybe they have gotten more busy than they can handle and have a boob working in the machine shop.
 









Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Just got off the phone with them. I didn't catch the guys name.

They sent the wrong pads (obviously), but he says the rear rotors are interchangeable. I just don't like the idea of having unalike rotors on my car!

They're sending replacements. Hopefully these ones will get here soon and work. I've leaving for vacation soon and would really like to have the new brakes installed by then!

He also said he checks the explorer forums and hasn't heard of anyone else having a problem. I told him I knew of others who also received bad rotors...


I'll be sure to keep everyone updated! ;)
 






Back
Top