Burning smell on test drive 2014 | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Burning smell on test drive 2014

wallyuwl

Member
Joined
March 19, 2014
Messages
19
Reaction score
0
Year, Model & Trim Level
2010 Equinox
A week or so ago we test drove a 2014 XLT with the standard V6. There was a very strong burning smell on my wife's test drive. It was really noticeable when we were stopped (no air flow). A few days before that I was at a different dealership and test drove a different 2014 XLT (same engine) and it didn't have that smell. The one salesman said it is the catalytic converter and the smell goes away after a couple hundred miles.

Is this the dreaded "exhaust smell in cabin" or actually what the salesman said? It didn't smell like exhaust, more like burning. Is it something that maybe they changed and the one I drove might have had a more recent build date?
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





boominXplorer

Elite Ranger
Elite Explorer
Joined
September 16, 2002
Messages
9,546
Reaction score
948
City, State
Virginia Beach, Va
Year, Model & Trim Level
00 4x4 Mounty
Its pretty normal for one to smell with under 25 miles on it
 






LukerDooker

Well-Known Member
Joined
March 25, 2013
Messages
886
Reaction score
11
City, State
N.E.
Year, Model & Trim Level
2013Limited 301A TuxBlack
...RRRUUUUUUUUUN AWAYYYYY ! :eek:;):(:D:mad::):eek::D:eek::D:eek::D:eek:
 






TYDFAN

Member
Joined
March 28, 2014
Messages
10
Reaction score
0
City, State
Nederland, Texas
Year, Model & Trim Level
2014 Ford Explorer Sport
Brakes burning in maybe??
 






s1000rr

Active Member
Joined
July 24, 2013
Messages
78
Reaction score
0
City, State
Jersey
Year, Model & Trim Level
2013 explorer sport
Theres a thread on here regarding a burning smell experienced in the cabin during stop and hard acceleration. I wouldnt even go back to the one who had that issue.
I believe it had to do with the catalytic converter, possibly something not sealed up properly. cant remember exactly
 






TheBigYahi

Member
Joined
August 26, 2013
Messages
27
Reaction score
1
City, State
Syracuse, NY
Year, Model & Trim Level
2014 Explorer XLT
I had the same really nasty smell on my test drive and then for a few days after mine was delivered. Nothing since.
 






BttlScars00x

Active Member
Joined
August 6, 2006
Messages
79
Reaction score
0
City, State
Chicago
Year, Model & Trim Level
2014 Explorer Base
Mine had a smell also when I first took delivery on it. Kind of a plastic/rubber burning smell. I'd say it probably stopped by 200 miles or so. I didn't really pay attention to when it stopped. It wasn't for very long though.
 






Top