• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

Burnt oil smell / Oil lamp goes on when full stop

Antz_2

New Member
Joined
April 12, 2019
Messages
1
Reaction score
0
City, State
Oranjestad
Year, Model & Trim Level
Ford Explorer 2007 xlt
Hi all, I have a Ford Explorer 2007 xlt. Lately I have changed the oil filter and the oil pan gasket. I have noticed that when I drive the car after a few miles it starts smelling like burnt rubber and when I come to a full stop (eg. at a traffic light) the oil lamp comes on and when I start driving again it goes away. I kind of feel like the car loses its power also when this starts to happen, when I accelerate it's like it doesn't have the same power as before.
any ideas what this could be? I recently changed the oil and checked if this could be the case (low oil) but it;'s not, the oil is filled up, the coolant level is ok.
I appreciate all the help.
Thnx!
 

974X4BLACKSPORT

Active Member
Joined
May 21, 2018
Messages
892
Reaction score
196
Location
FL
City, State
hudson
Year, Model & Trim Level
BLACK 1997 SPORT 4 BY 4
Some engines place the oil filter directly over the exhaust pipes, and when the filter is removed for oil and filter changing, left over oil burns of the pipes and emits an odor. I dont know what engine you have, or if this is even applies in your situation, just a thought. As for the "oil light", is this the "low oil" light, or "oil pressure" light? Have you put a code reader/scanner on it to check for stored codes?
 
Top