California smog | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

California smog

californicated

New Member
Joined
October 26, 2014
Messages
2
Reaction score
0
City, State
Hesperia Ca
Year, Model & Trim Level
96 ford ranger
Hello to all knowledgeable folks here at explorerforum.com. I have a question concerning my 96 ranger 4.0l . I recently put in a new used motor,after the install the engine fired up no problem compression was good on all cylinders,the motor seems to me lacks in power as I remember I like the 4.0 the reason I purchased the truck was because of the motor, anyways it seems to be using a lot of fuel also.i have been reading a lot about the 4.0 with the same problems. before I ask let me explain what all I have done to the engine so far new plugs and wires new air cleaner new fuel filter cleaned MAS new TPS i used seafoam because the motor had been sitting in storage for some time and i thought it would help maybe well as I was driving one of the two houses that come down from the DPFE blew out when I say blew out it did just that it had an inch and a half inch rip in the in the downstream hose on the EGR tube,so i replaced it that was a week ago,so tonight I am driving and the same thing happened again my question is this. could my catalytic converter be plugged up creating to much back pressure,and could that also be why the motor seems to lack power I could use some help on this I don't want to get californicated at the smog station thanks
 




Top