Clutch going bad | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Clutch going bad

MD11007

Member
Joined
July 31, 2003
Messages
12
Reaction score
0
City, State
Gainesville, FL
Year, Model & Trim Level
99 Sport
My clutch pedal on my 99 sport used to have pressure from when you first put your foot on it till it was totally depressed. Now it only has pressure at the very end. Does this mean I need a new clutch or is it just the master slave cylinder? If so does anyone know where I can get a new clutch for cheap.
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




MrShorty

Explorer Addict
Joined
December 27, 2001
Messages
5,078
Reaction score
17
City, State
Spanish Fork, UT
Year, Model & Trim Level
92 XLT and '87 Bronco II
Hows the fluid level in the clutch reservoir?
 
<



MD11007

Member
Joined
July 31, 2003
Messages
12
Reaction score
0
City, State
Gainesville, FL
Year, Model & Trim Level
99 Sport
Clutch

Ill have to check it and get back with ya. Any idea where thats located at? I have the V-6 4.0
 
<



williecume

Well-Known Member
Joined
February 4, 2002
Messages
800
Reaction score
1
City, State
Arlington, TX
Year, Model & Trim Level
97 xlt & 98 mounti
drivers side on the fender near the hood beside the fuse box in the engine compartment.

[email protected] i think i just lost it...hope this helps.
 
<



Doug

Moderator Emeritus
Joined
August 30, 2001
Messages
5,722
Reaction score
3
City, State
Sykesville, MD
Year, Model & Trim Level
2020
Are you having problems with shifting? or is the feel of the pedal just different then what it used to be?
 
<



MD11007

Member
Joined
July 31, 2003
Messages
12
Reaction score
0
City, State
Gainesville, FL
Year, Model & Trim Level
99 Sport
clutch

The pedal is just differnt shifting is fine for the most part I just have to adjust that thier is only pressure at the end its like im only using the 1/4 at the end to shift and its a dead pedal til then.
 
<



Doug

Moderator Emeritus
Joined
August 30, 2001
Messages
5,722
Reaction score
3
City, State
Sykesville, MD
Year, Model & Trim Level
2020
How many miles are on it? you should try bleeding it and seeing if that fixes it. it sounds like your slave cylinder might be leaking.
 
<



EXPLORINGVA

Member
Joined
July 25, 2002
Messages
24
Reaction score
0
City, State
Williamsburg, VA.
Year, Model & Trim Level
'91 XL 2WD 5 Spd
Just went through this same mess with my 91'. Lost clutch pedal pressure, checked the master cylinder and was loosing fluid. So I did it up. New heavy duty clutch($150) and to elliminate any any questions later, a new slave cylinder($89). 3 hours to get the tranny out & install new parts. Another 2 hours getting the d*^n spline to go back in. Have fun!
 
<



Peter

Well-Known Member
Joined
December 10, 1999
Messages
319
Reaction score
0
City, State
Virginia
Year, Model & Trim Level
96 XLT
ill tell ya my two cents...just replaced a clutch and slave with 50000 miles on them after I couldnt shift and a leaky master cyylinder that was original (replaced it too)...worht the money, jus find someone to do it cheap as this is a labor intensive thing...i got a centerfoce clutch from Napa for a little over 200 bucks, not a bad price I thought. There are so many things that could be going wrong, and when i saw fluid down near the master I just decided that the "conversation" between the slave and master was bad and that they all needed to go!
 
<



Top