Continued Idle surge | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Continued Idle surge

sohcsol

New Member
Joined
February 16, 2006
Messages
5
Reaction score
0
City, State
Chehalis, WA
Year, Model & Trim Level
91 4x4
I have 1991 XLT and have been through an array of parts solving a very poor fuel economy problem. After a new ECM, ECT, IAC, and a thorough cleaning of the throttle body, IAC, and MAF wires the fuel economy has gotten much better, but I still have an idle surge which tends to show up once the vehicle is warm and only every once in awhile. it surges from about 550-800 RPM, and shortly after the check engine light comes on. Pulled codes (engine on) and recieved:

79: MAP/MAF/Baro insufficient change during goose test

SHould I try cleaning the MAF wires again or lok at the Baro sensor? Don't have a volt meter with an "hz" setting to test the Baro so I am hoping for some guidance. thanks
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




ExplorerDMB

Moderator/Technician
Moderator Emeritus
Joined
January 26, 2004
Messages
6,131
Reaction score
9
City, State
Mechanicsville, Virginia
Year, Model & Trim Level
2004 Acura TL
barometeric pressure is probably not the issue. You more than likely need a new MAFS. If your hurting for money - a used one. That would be my best bet.

-Drew
 
<



bstone

Active Member
Joined
March 9, 2004
Messages
56
Reaction score
0
City, State
Boston, MA
Year, Model & Trim Level
93 Explorer XLT 4wd 4dr
I just replaced me MAFS with a reman. $100 retail and then I got $30 for the core, so $70. It is a major improvement alreayd and all but 10 minutes of work.
 
<



sohcsol

New Member
Joined
February 16, 2006
Messages
5
Reaction score
0
City, State
Chehalis, WA
Year, Model & Trim Level
91 4x4
I'll give it a try, thanks for the help.
 
<



Maniak

Moderator-Stock 91-94
Elite Explorer
Moderator Emeritus
Joined
February 9, 1999
Messages
12,064
Reaction score
124
City, State
Vail, Arizona
Year, Model & Trim Level
1992 XLT 4x4
I didn't see testing the TPS as something you did.

There is even a thread on how to adjust it for better throttle repsonse on the site, but in general, you want to make sure that voltage doesn't move when the throttle is closed, and that as you open the throttle that the voltage increase slowly, and smoothly (matching you opening the throttle)

BTW.. to check the hz of the baro sensor you can use a tachometer set to 6cyl.. (I just had to do that to check a MAP sensor on an 88 ford)

~Mark
 
<



Top