Damsel in Distress, Explorer will not work! | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Damsel in Distress, Explorer will not work!

bevngra

Member
Joined
March 21, 2010
Messages
10
Reaction score
0
City, State
oxford uk
Year, Model & Trim Level
1997 explorer
Hi I'm not sure what the problem is but I've read if you park your explorer in certain areas it will not start?
This morning I tried to get into my 1997 Explorer, I couldn't open it with my remote fob, I used the key and then it didn't turn over or attempt to, I noticed the red round key light was flashing rapidly??

I have now got back in the car and the light is not dispaying at all?? (i'm sat in it at the mo) Hold on its started to flash rapidly again!!


Any advice would be great,

Bev
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





first guess would be a dead battery, do anything of the other lights work? (interior exterior or the radio?)
 






first guess would be a dead battery, do anything of the other lights work? (interior exterior or the radio?)

Absolutely nothing works, electric seats, interior lights, radio headlights nothing, not even the central locking. The only light illuminating is the round red one with a cross through the key and it flashes rapidly.
 












Get a jump start, sounds like a very dead battery. How long did it sit since last started?

Monday, and it would start instantly!!!! Would it be anything to do with this immobiliser fault that I have heard about? (Thanks by the way)
 












I'm not 100% familiar with it, but would expect the immobilizer to kill the starter, not all power to all electrics. So it sounds odd.

Very odd, as it doesn't turn over and no electrics! I'll get it jump started. Will this not blow up the ECU?
 






no, but i would leave the key out while you hook up the cables.
 






The only light illuminating is the round red one with a cross through the key and it flashes rapidly.

sounds like something called PATSII failure. The truck forgot what keys are allowed to start it, when faulted nada, nothing. . . .stealership to reset the module for the keys. Usually it happens with a dead battery. Search on PATSII you should find some reading.
But your not in North America and i have no idea whats different on the other side of the pond. . . .
 






Back
Top