DDM HID problem | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

DDM HID problem

Did a quick search and didn't find much, so here's the deal. I got some 35W 5000K HID's from DDM about a week ago, just the low beam. Hooked them up, all good to go and they worked like a charm…for a few days.

First off, when I turn the fog lights on now the high beam light comes on, that doesn't make sense to me but I think I've seen more people with that problem so I'll figure that out later if someone can't explain.

My main problem is now probably about 40-50% of the time the driver's side headlight won't come on at first. I have to turn the headlights off and back on usually once, sometimes twice for it to fire. I know that's really bad to do with HID's so I'm assuming it's just a bad ballast. My passenger side ballast buzzes which is normal and the driver's side never makes any noise at all. I heard such good things about DDM so maybe I just got unlucky but wanted to see if anyone had extra insight, or if it's quite simply a bad ballast. Are they pretty good with their warranty? Thanks for the help in advance.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





chetrick87

Well-Known Member
Joined
March 29, 2013
Messages
154
Reaction score
0
City, State
CHETRICK87@GMAIL.COM
Year, Model & Trim Level
2005 ford explorer xlt
If you think it's a ballast issue, can't you just switch then and see if it still hesitates on that side or the other side? Also how long did it take you to get your order? I ordered two weeks ago yesterday and the tracking still says it's in China.
 






TGtrac05

Well-Known Member
Joined
June 14, 2012
Messages
205
Reaction score
0
City, State
Texas
Year, Model & Trim Level
2005 Sport Trac XLT
Yeah I'll probably try that and see. And DDM takes a while, that's the biggest complaint I've seen is the wait time. It took about 2 weeks for mine to get here, and on the tracking info it said it was in china the whole time and pretty much the next thing said it was delivered, so not really "tracking info." But I looked into the warranty more and apparently they can be a pain in the ass with it so hopefully I don't have troubles if I have to replace it.
 






chetrick87

Well-Known Member
Joined
March 29, 2013
Messages
154
Reaction score
0
City, State
CHETRICK87@GMAIL.COM
Year, Model & Trim Level
2005 ford explorer xlt






JimiJak

Active Member
Joined
January 31, 2014
Messages
75
Reaction score
0
City, State
Grand Rapids, MI
Year, Model & Trim Level
2014 Ford Explorer Sport
From what others have found, the heavy duty relay seems to fix the bulb out / hesitation problem. It appears it's just not getting enough juice to ignite from what I've read.

Also, I installed a DDM hid kit today on another vehicle, it took them about two and a half weeks to get it to me...I was very impatient. Otherwise really happy with the products I've gotten from them. I will definitely order from them again, but at least I'll know what to expect next time.
 






chetrick87

Well-Known Member
Joined
March 29, 2013
Messages
154
Reaction score
0
City, State
CHETRICK87@GMAIL.COM
Year, Model & Trim Level
2005 ford explorer xlt
Yeah it took 3 weeks for mine to come in but I'm happy with the product and will probably order again.
 






chetrick87

Well-Known Member
Joined
March 29, 2013
Messages
154
Reaction score
0
City, State
CHETRICK87@GMAIL.COM
Year, Model & Trim Level
2005 ford explorer xlt
And they threw in free leds. I think they are for the turn signals but I'm not sure.
 






TGtrac05

Well-Known Member
Joined
June 14, 2012
Messages
205
Reaction score
0
City, State
Texas
Year, Model & Trim Level
2005 Sport Trac XLT
Darn, I was counting on not needing the relay since they were the 35W ones and their website said most vehicles wouldn't need it. I guess we fall into that small category that does. But I know DDM has a good reputation and I still recommend them to my friends, just wish I would have gotten the relay from the start

And I ordered mine literally one day before they started the free LED's deal. Oh well, I didn't know what I would use them for anyway
 






MustangP51

Explorer Addict
Joined
January 16, 2005
Messages
1,385
Reaction score
2
City, State
Connecticut
Year, Model & Trim Level
2009 Limited V8
Run a pair of jumper wires from the ballast to the battery and see if the HID fires up every time. If it functions correctly you will need to add a heavy duty wiring harness. If it doesn't there is a problem with the ballast.
 






Top