"Disparate photos" ? | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

"Disparate photos" ?

grrtrainman

Well-Known Member
Joined
October 19, 2011
Messages
191
Reaction score
1
City, State
Western Mass, (summer), & SW Florida, (winter).
Year, Model & Trim Level
'13 Limited 4WD 302A Tow
http://photobucket.com/grrtrainmansExplorer

Okay guys, this is a big experiment for yours truly, (my first attempt on posting photos here). Fingers crossed. Cut me some slack!

I have tried to post some "different" pics of my 2013 Explorer!

Hey, live and learn!

:eek:
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Very cool! :thumbsup:
 






Nice! This one is my favorite:
516c7f65.jpg


Here's what we were doing in the Ocala National Forest yesterday:
IMAG0119.jpg

IMAG0127.jpg

IMAG0133.jpg
 






http://photobucket.com/grrtrainmansExplorer

Okay guys, this is a big experiment for yours truly, (my first attempt on posting photos here). Fingers crossed. Cut me some slack!

I have tried to post some "different" pics of my 2013 Explorer!

Hey, live and learn!

:eek:
Very nice. You had me guessing on the pic (#12) of the 4 amber LED's. I thought that it was part of the headlight assembly at first. After closer inspection I thought I recognized it and went and checked mine and confirmed what it was.

Peter
 






Bobby, did you remove your post? I received an email showing it but I don't see it here.:scratch:
The Check Engine light will often come on if you put the 'accessory mode' on but don't start the vehicle. Nothing to worry about.

Peter
 






Yes I did Peter, I was going to post that the lights on pic #12 almost fooled me and gotme thinking twice big time. Re: check engine light, later I noticed that theEX was in Acc mode. Those are cool pics though.
 






Back
Top