• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

Door locking problem

agarbs87

New Member
Joined
August 31, 2005
Messages
43
Reaction score
0
City, State
Connecticut
Year, Model & Trim Level
none
i have a 1997 ford explorer 2 door sport.

The problem is sometimes the door will not want to unlock. I have the buttons on my key and when i press them it makes the noise like it wants to unkock but it doesnt. I try to use the key itself in the door but that doesnt work either. I usually have to go through the passenger side and pull the lever on the inside to open the drivers door. I dont know if it is just freezing from the cold weather but i just sprayed the locking mechanism on the door with WD40. Can it be anything else?
 
Join the Elite Explorers for $20.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.


budwich

Well-Known Member
Joined
May 4, 2005
Messages
3,246
Reaction score
3
City, State
Ottawa, Ont
Year, Model & Trim Level
96 XL
If there is a sound coming from the door like it is trying to unlock, then it is likely mechanical (ie. linkages). If there is no sound coming from the door, then it is likely electrical (ie. broken / disconnected wire in the door or door jam area).
 

agarbs87

New Member
Joined
August 31, 2005
Messages
43
Reaction score
0
City, State
Connecticut
Year, Model & Trim Level
none
yeah there is a sound coming from the door like it wants to unlock. I went out this morning and it wouldnt unlock, i had to go throught the passenger side. Like i said it only does this sometimes. Is there any specific linkage that i should check. Pictures or directions would help if possible. THANKS!
 

dock

New Member
Joined
May 24, 2003
Messages
32
Reaction score
0
City, State
Orlando, Fl
Year, Model & Trim Level
'99 Sport
I don't have keyless entry, but this happens to my locks about every 6 months.

I just spray some WD-40 inside the key entry, and it works fine again. The first time they started sticking (and eventually I couldn't get in at all) the dealer charged me $40 to grease them.

In fact my passenger lock is doing this right now, so I'm about to go outside and spray it.
 

DeathsArrow

Member
Joined
June 30, 2003
Messages
76
Reaction score
0
City, State
Bristol, CT
Year, Model & Trim Level
'98 Sport
There are a few threads about this with no easy solution. Do a search on door latches.

The driver side lock on my 98 Sport is doing the same thing.
 

keato7

New Member
Joined
July 8, 2005
Messages
17
Reaction score
0
City, State
Topeka, Kansas
Year, Model & Trim Level
'98 Sport
My '98 Sport did the same thing turned out to be the locking mechanism in the door needed to be replaced. You might look into it, I've heard this is a common problem from other Sport owners around here. Good Luck
 

mikeh

Active Member
Joined
August 2, 2001
Messages
262
Reaction score
0
City, State
St. Louis, MO
Year, Model & Trim Level
98 XLT SOHC V6
I'd guess you need a new latch. It's about $50 from Ford and a real pain to install. I had the same problem with mine.
 

witchdoctor

Gringorican
Joined
August 8, 2003
Messages
245
Reaction score
0
City, State
Chattanooga, Tennessee
Year, Model & Trim Level
98 Sport, 02 Triumph S4
broken spring in latch. no way to fix it. like mikeh said ^^^^
 

agarbs87

New Member
Joined
August 31, 2005
Messages
43
Reaction score
0
City, State
Connecticut
Year, Model & Trim Level
none
If i had a broken spring wouldnt it not work all the time? because mine only does it sometimes (about 2 times a week)
 

Top