EGR Issue (HELP) | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

EGR Issue (HELP)

rmwags

Member
Joined
March 16, 2009
Messages
11
Reaction score
0
City, State
Hiawassee, GA
Year, Model & Trim Level
05 XLT 4WD
Happy St. Patty's Day...

Here's my issue.
I've replaced my DPFE, EGR valve and EGR Vacuum regulator. I've checked all vacuum hoses, I've put a replacement PCM but am still receiving OBD code 332. EGR valve not opening.
Does anyone know which sensor or sensors feed the PCM to open and close the EGR?
Or is it another issue I've missed.
Any help is grateful....:mad:
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




boggs1227

Explorer Addict
Joined
February 19, 2008
Messages
1,472
Reaction score
4
City, State
Flowery Branch , Georgia, 1994 sport 2wd auto
Year, Model & Trim Level
2005 colorado 2wd 5spd
the dpfe is connected to the pcm to give exhaust data ...once the pcm reads the info it tells the egr solinoid to start opening and closeing the egr valve.


...did you make sure the dpfe lines are connected right ( small and big ) ??


are you just haveing the cel come on and are haveing idleing issues ?
you have checked ALL vac lines right ? ... ( not just the ones for egr) then check the others like transmission modulator,fuel pressure regulator,climate control lines .

to many questions here to ask .....

volt meter checked the sensors ?
checked for loose wire harness's ?
etc .......
 
<



rmwags

Member
Joined
March 16, 2009
Messages
11
Reaction score
0
City, State
Hiawassee, GA
Year, Model & Trim Level
05 XLT 4WD
the idle is good. i've checked the egr vacuum hoses only. i was having mpg issues and had a system scan done. the said the dpfe was bad. so i replaced it. i never got a code before changing the dpfe. then i got the 332 code. thats when i went ahead and changed the egr valve and control solenoid.
 
<



rmwags

Member
Joined
March 16, 2009
Messages
11
Reaction score
0
City, State
Hiawassee, GA
Year, Model & Trim Level
05 XLT 4WD
also, which other sensors? TPC, MAF, TCC?
 
<



mikeinri

Explorer Addict
Joined
January 18, 2007
Messages
1,110
Reaction score
6
Year, Model & Trim Level
04 Explorer, 94 XLT (RIP)
Take the code to AutoZone. They can print up a full diagnostic procedure to follow (on a cash register tape). It will definitely involve a voltmeter, checking various wires with the engine in different states, perhaps vacuum, etc.

Hope this helps.

Mike
 
<



rmwags

Member
Joined
March 16, 2009
Messages
11
Reaction score
0
City, State
Hiawassee, GA
Year, Model & Trim Level
05 XLT 4WD
Thanks Mike & Boggs...I was hoping not to get into that..Time wise. Thanks
 
<



Top