egr valve for 93 explorer location | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

egr valve for 93 explorer location

Dennis

New Member
Joined
March 14, 2011
Messages
3
Reaction score
0
City, State
Virginia Beach, VA
Year, Model & Trim Level
'93 4x4 and '91 XLT
I have 93 explorer XLT 4x4 with a 4.0/241 engine mtd 5/93 engine it was stalling and smelling like bad eggs. I replaced catalytic converter. It took care of the smell and gave me more power but it stall still. Cleaned the air intake but still stalls. Then I ran diags and got error codes of 32, 33, and 34 said bad egr valve. But I can not find its location. It is not where the 94 is.
 




Dennis

New Member
Joined
March 14, 2011
Messages
3
Reaction score
0
City, State
Virginia Beach, VA
Year, Model & Trim Level
'93 4x4 and '91 XLT
First my Explorer does not have EGR Valve so codes not valid codes. Second when I replaced catalytic converter I knock loose carbon off pipes it is blocking air flow on something but I do not know what?

Anything can go wrong will.
 




backfrmcolorado

Well-Known Member
Joined
February 21, 2010
Messages
552
Reaction score
0
City, State
Commerce Twp, MI
Year, Model & Trim Level
'94 Eddie B explodwhore
Welcome to the site. How many miles are on the old girl? Its possible that the codes given are slightly differernt than what is really there. I had to check error codes up to 6 times befor i came across what was close to the problem.
 




Dennis

New Member
Joined
March 14, 2011
Messages
3
Reaction score
0
City, State
Virginia Beach, VA
Year, Model & Trim Level
'93 4x4 and '91 XLT
Problem was a bad battery, MAF Sensor plus catalytic converter and codes was for ABS brake system.
 




Top