electrical issue with front map light | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

electrical issue with front map light

resq302

Active Member
Joined
November 15, 2007
Messages
82
Reaction score
0
City, State
Boonton, NJ (Morris County, NJ - 45 mins West of New York City)
Year, Model & Trim Level
2008 explorer eddie bauer
My wife and I just picked up her new / used 2008 Eddie Bauer Explorer last night and the dealer said that they repaired the issue that was with the front dome / map light and vanity mirror lights in the sun visors. Well, when we picked up the car last night, the blasted lights still didn't work. They said to bring it back and since it has the certified pre owned warranty, they will fix it no charge. I checked the owners manual to see which fuse it is and the fuse checked out good. Also on that circuit is the puddle lamps, homelink, interior lights, instrument panel lights, and all them work with the exception of front map lights (front dome light) and the visor mirror lights. The fuse is ok for the interior lights. Anything else I should check? My gut feeling is that there is a short or broken wire some place. Should I wait the week and let the dealer mess with it and be without a vehicle for who knows how long or should I try to find the problem? Im a little concerned messing with anything as the vehicle has the canopy / curtain air bags which I know is up in the headliner and A post.

Your thoughts are appreciated.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Explorer_PL

Elite Explorer
Joined
November 16, 2007
Messages
2,911
Reaction score
211
City, State
Rockland County, NY
Year, Model & Trim Level
06EB V8
I have the same problem on my 06 EB, the front lamps do not work unles I turn the dimmer all the way and all the lights come on inside, but never just the front. I was told it is Smart Junction Box, cost around $ 700 to replace. If they can fix it, have them do it, otherwise it's going to cost you big $$$.
 






resq302

Active Member
Joined
November 15, 2007
Messages
82
Reaction score
0
City, State
Boonton, NJ (Morris County, NJ - 45 mins West of New York City)
Year, Model & Trim Level
2008 explorer eddie bauer
Whatever the problem is, I have narrowed it down that it is not the wiring where the connection at the A post is up to the actual map light itself. The 4 wires going up to the light have continuity down to the connector at the A post. My guess it is somewhere in the main wiring harness. Funny thing is that when I was playing around with the dimmer switch, one time I turned it to "on" and the front map light did not work, second time I did it, the map lights came on with the dimmer switch. Im almost wondering if it is something with the dimmer switch.
 






Explorer_PL

Elite Explorer
Joined
November 16, 2007
Messages
2,911
Reaction score
211
City, State
Rockland County, NY
Year, Model & Trim Level
06EB V8
I also thought it was the switch. I replaced mine because the original one just fell apart inside (the connectors detached from the plastic wheel). I got one used from ebay for about 25, new one is around 100. But that did not help my issue. You can take apart the switch and see if anything is loose.
 






resq302

Active Member
Joined
November 15, 2007
Messages
82
Reaction score
0
City, State
Boonton, NJ (Morris County, NJ - 45 mins West of New York City)
Year, Model & Trim Level
2008 explorer eddie bauer
Whatever is the problem is isolated to the constant hot wire either being loose, broken, or disconnected. I have to see if there is constant power going to it or not. Do you know which wire is the constant hot for the map lights and vanity mirror lights?

If it is something simple that I can do in no time, I'll fix it because the dealer is 45 mins away from me. The car was a Certified Pre-Owned car and they said everything would work and also said they fixed it which they obviously did not. So, needless to say, if I can't fix it quickly, they are getting it back and will have it till they get it fixed right with a loaner car for however long it takes.
 






Explorer_PL

Elite Explorer
Joined
November 16, 2007
Messages
2,911
Reaction score
211
City, State
Rockland County, NY
Year, Model & Trim Level
06EB V8
Sorry, I do not have wire schematics for that, I am sure someone here will chime in.
 












resq302

Active Member
Joined
November 15, 2007
Messages
82
Reaction score
0
City, State
Boonton, NJ (Morris County, NJ - 45 mins West of New York City)
Year, Model & Trim Level
2008 explorer eddie bauer
Thanks for the diagram. I popped down the small console that has the home link, switch for the moon roof, and the map lights and tested the yellow wire. It has constant 12 volts with the door open. The green wire with violet tracer had zero volts. Funny thing is that I pulled the connector back in, had only one light come on for the interior light (pass side bulb but reflected down to the driver side) and then I tried the vanity mirror lights, they worked and then stopped. At the same time, the front interior light went out. Out of curiosity, I tried both map lights which then worked. I then tried them again and worked. I unplugged the connector to find out why the map lights worked but not the interior lights and then after plugging it back in the interior light (still only one side) worked but not the map lights or the vanity mirror lights. Something aint right for sure.
 






resq302

Active Member
Joined
November 15, 2007
Messages
82
Reaction score
0
City, State
Boonton, NJ (Morris County, NJ - 45 mins West of New York City)
Year, Model & Trim Level
2008 explorer eddie bauer
Ok, just went out and tried it again. Map lights now both work but the front dome light is not working as well as the vanity mirror lights. The green with violet tracer wire still has 0 volts at the map light. At the connection down by the A post and the dash, the green with violet tracer has .55 volts. I tried doing a continuity test of the ground wire in the harness and at the connection where the dash and A post meet, and the ground (black) wire in the dash harness part and with the continuity tester hooked up the wire harness to the tester with the other lead going to bare metal, it was ok. Previously checked was the harness that goes up the A post up to the console which also had all wires checked for continuity and all were good.

I am totally baffled as to why the green wire works sometimes and sometimes it doesnt. Is there some kind of a relay that works in conjunction with the green with violet tracer wire?
 






resq302

Active Member
Joined
November 15, 2007
Messages
82
Reaction score
0
City, State
Boonton, NJ (Morris County, NJ - 45 mins West of New York City)
Year, Model & Trim Level
2008 explorer eddie bauer
Update - ( I guess I spoke too soon!) Well, as I was taking our 1 yr old to the doctors today, while I was at a stop light I decided to try the map lights and see if they still worked or not. Nope! They are dead again and now the dome light isn't coming on. Seems as if everything died all together again. Looks like it is the dealerships problem since they said they "fixed it" before we took delivery and when we went to pick it up, it still wasn't working. At least it is a Certified Pre - Owned car and has the extra warranty!!!!!!
 






resq302

Active Member
Joined
November 15, 2007
Messages
82
Reaction score
0
City, State
Boonton, NJ (Morris County, NJ - 45 mins West of New York City)
Year, Model & Trim Level
2008 explorer eddie bauer
Well..... heard back from the dealer today and the service manager said that the new sunvisor with vanity mirror and light seemed to be the problem as they said there was a short in the wiring which was causing all the problems. They had to order a new sun visor and said it will be in tomorrow. The reason why the sporatic working of the dome light and map lights was because there is a module that senses the positive and negative current and will limit or shut down certain things if there is a short. Hence, exactly what was happening with our car. The module was recently replaced (first time we had the problem before we took delivery) and was around $300 from what the sales manager told us. The service manager said that the module was ok this time but had to be reset using a computer. Electrical things like this make me love my 69 Charger more and more. Tomorrow I shall see if it is fixed or not and will report more then. Till then, wish me luck!
 






resq302

Active Member
Joined
November 15, 2007
Messages
82
Reaction score
0
City, State
Boonton, NJ (Morris County, NJ - 45 mins West of New York City)
Year, Model & Trim Level
2008 explorer eddie bauer
Well, just got the explorer from the dealership a couple hours ago and all seems well. The whole cause of the problem was the new pass. side sun visor that had the vanity mirror with light in it. The wires must have been shorted out somewhere inside the visor. They also had to reset the control module for the lights as it has an internal breaker that can be reset by a Ford computer system. So far, the 45 min trip home, everything works as it should!
 






alexh

New Member
Joined
January 3, 2013
Messages
1
Reaction score
0
City, State
Kansas
Year, Model & Trim Level
2007 Explorer Limited V8
homelink vanity mirror lights not working

So my passenger side vanity mirror fell off the visor the other day and since then my homelink, map lights, and driver side vanity mirror stopped working. I'm guessing it's all related and I've ordered a new sunvisor hoping that will fix it. Just curious as to the whole "resetting the control module for the lights" thing that RESQ302 mentioned? Is that something that Ford will have to do if the new visor doesn't fix my prob?
 






resq302

Active Member
Joined
November 15, 2007
Messages
82
Reaction score
0
City, State
Boonton, NJ (Morris County, NJ - 45 mins West of New York City)
Year, Model & Trim Level
2008 explorer eddie bauer
According to the Ford dealership, yes this is something that only "they" can do.
 






hmumm

Member
Joined
October 17, 2013
Messages
10
Reaction score
0
City, State
Denver CO
Year, Model & Trim Level
2008 Ford Explorer
I have this exact problem with my map lights dome lights and vanity mirror lights,,,however, if I wiggle my keys in the ignition, I can make them all come on and work correctly...my thoughts are that these issues are a part of the infamour dreaded IGNITON issue we all have with these models...the ignitions is loose inside, and creates internal shorts wiggle it a while, and you can get the tumblers in the correct alignment and ki8ll the short and amazingly the lights work....try it....there were also multiple posts about how the map lights came n and the front seat moved,,,,that also happenes when you wiggle your keys in the ignitions so we are all chasing out butts and it all stmes from the GD ignition FORD put in these things....
 






hmumm

Member
Joined
October 17, 2013
Messages
10
Reaction score
0
City, State
Denver CO
Year, Model & Trim Level
2008 Ford Explorer
I sent you the wire diagrams and connector pin-out...check your inbox.

Could you send me the schematics of the map lights and visor lights also? I have the same problem ..thx in advance...
 






martinezcvx

New Member
Joined
June 30, 2014
Messages
3
Reaction score
0
Year, Model & Trim Level
2007 Explorer
[Could you send me the schematics of the map lights and visor lights also? I have the same problem ..thx in advance...
hmumm is offline Reply With QuoteQUOTE=hmumm;3364459]Could you send me the schematics of the map lights and visor lights also? I have the same problem ..thx in advance...[/QUOTE]
 






martinezcvx

New Member
Joined
June 30, 2014
Messages
3
Reaction score
0
Year, Model & Trim Level
2007 Explorer
I have the same problem in Venezuela

[could you send me the schematics of the map lights and visor lights also? I have the same problem ..thx in advance...
Hmumm is offline reply with quotequote=hmumm;3364459]could you send me the schematics of the map lights and visor lights also? I have the same problem ..thx in advance...
[/quote]
 






greenhornet3147

Well-Known Member
Joined
August 28, 2002
Messages
189
Reaction score
0
City, State
lawrenceville, nj
Year, Model & Trim Level
2010 Explorer XLT
Map lights

I want to make sure I'm reading this right if my dome lights work but both my front and back map lifts don't work the issue is with the viser.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





hmumm

Member
Joined
October 17, 2013
Messages
10
Reaction score
0
City, State
Denver CO
Year, Model & Trim Level
2008 Ford Explorer
I have this same problem only mine comes from the vanity mirror on the passenger side falling apart. the cheap lid came off and kept the light on and burned up the wires. new visor with mirror = $150 on ebay. I am not sure this will fix my problem because of all the other posts saying how many other issues this little lid causes down the line...
 






Top