Engine codes PO300 & PO304 | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership!
    If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

Engine codes PO300 & PO304

Flydog

New Member
Joined
January 6, 2006
Messages
8
Reaction score
0
City, State
New Albany, Ohio
Year, Model & Trim Level
1993 Explorer Eddie Bauer
I have a 2002 Explorer, V8 and on a trip out of state a few days ago the check engine light came on. It has a miss and the fuel miles per gallon went down. Normally I get anywhere from 17 mpg to 19 mpg combined city and highway driving. I was pulling a 17 ft boat and the trip was about 300 miles each way. My gas mileage dropped to as low as into the 12's and ranged up to the 14's. Now that I am back home and not towing anything my mpg has went up into the 16's.

My check engine light came on and was flashing during the trip and after I got home it quit flashing and now stays on constantly. I had the engine codes pulled at Autozone and I got codes PO300, PO304 and PO316. Also the guy at Autozone said the code checker showed my miss to be on cylinder # 4. My plan is to check the spark plug and coil on cylinder # 4.

Has anyone else had a similar problem with a single cylinder seeming to be the source of the miss ? If so what was the problem and solution.

Also does anyone have any suggestions other than the coil / plug ?

Thanks,

Flydog
 






CasterTroy

Member
Joined
December 14, 2004
Messages
39
Reaction score
0
City, State
Kernersville, NC
Year, Model & Trim Level
2004 XLT Exp V8
Also does anyone have any suggestions other than the coil / plug ?

Thanks,

Flydog

Any updates? Any solutions?

Same problem. Flash at Auto Zone said PO316 and the other was for cylinder # 8

158K plugs replaced at 100K Coil pack 8 was replaced last night. Now check engine light flashes and hesitation under 1500 rpms. Auto Zone OBD said possibly cam position sensor
 






rocco123

Well-Known Member
Joined
February 24, 2002
Messages
877
Reaction score
11
City, State
Endicott, NY
Year, Model & Trim Level
1994 XLT & 2002 Limited
U sure the plugs are all tight? She may be getting ready to spit out a plug. Been there.
 






Top