Engine hits revlimiter in gear at 4200rpm, but at 5200rpm in neutral | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

Engine hits revlimiter in gear at 4200rpm, but at 5200rpm in neutral

atistang

Well-Known Member
Joined
December 17, 2007
Messages
152
Reaction score
0
City, State
Ohio
Year, Model & Trim Level
94 XLT
ok, i just had my A4LD rebuilt, i think the trans is slipping, they keep trying to tell me something is wrong my my engine.

If your cruising down the road and you floor it, it will kick down and go, once it gets to about 4200rpm it acts like its hitting the rev limiter. Aside from that it seems like it slips, if you roll into the throttle the rpms will go to about 3k and hold there while you accelerate.

if you put it in neutral you can rev it all the way to 5200 or so.

is there anything that could cause it to hit a lower rev limiter in gear and not in neutral? I don't feel like arguing with these guys about it if its just something simple.
 


Holiday Special! Join the Elite Explorers $20 for 2 years! Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




Mickelsons

Well-Known Member
Joined
November 9, 2007
Messages
155
Reaction score
0
City, State
Boring, Oregon
Year, Model & Trim Level
'91 explorer
Mine acted kind of like that before I changed the fuel pump and filter.
 








atistang

Well-Known Member
Joined
December 17, 2007
Messages
152
Reaction score
0
City, State
Ohio
Year, Model & Trim Level
94 XLT
Mine acted kind of like that before I changed the fuel pump and filter.

thanks for the reply

i'm driving it home tomorrow, i'm gonna adjust the modulator, kick down cable and both bands. if it still does it then i'll replace the fuel filter. if it still does it then i'm taking it back and not being nice this time.

my roommate also has a 94 xlt (same thing as mine) with about 40k more miles on it, if i power brake his it goes to about 2100 and holds. If i do that to mine it goes above 3k so i know somethings not right.

I think i'm gonna find a shop manual and find the exact specs for a stall speed test, that way i can show them, then tell then one last time to fix it before a lawyer is involved
 




atistang

Well-Known Member
Joined
December 17, 2007
Messages
152
Reaction score
0
City, State
Ohio
Year, Model & Trim Level
94 XLT
im not an expert.. but that seems like a trans problem, or a shift linkage problem

i'm sure something is wrong with the trans, just not to sure if it is an adjustment i can make or something the transmission shop didn't put together right
 








atistang

Well-Known Member
Joined
December 17, 2007
Messages
152
Reaction score
0
City, State
Ohio
Year, Model & Trim Level
94 XLT
my bet is they didnt put something back together right.

if thats the case its probably gonna come down to me getting a lawyer to get them to fix it. they keep blaming the problems on everything but the transmission
 




atistang

Well-Known Member
Joined
December 17, 2007
Messages
152
Reaction score
0
City, State
Ohio
Year, Model & Trim Level
94 XLT
no to mention when i brought it to him i still had 1st and 2nd and i did a big smokey burnout power braking it right before i brought it to him.
 








atistang

Well-Known Member
Joined
December 17, 2007
Messages
152
Reaction score
0
City, State
Ohio
Year, Model & Trim Level
94 XLT
well dont mention the big smokey burnout to them.. that would be bad

that was before he started working on it, i still had 1st, 2nd, and 3rd, just no over drive and lazy shifts
 




Four0Sport

Jack Pewe
Elite Explorer
Joined
August 26, 2004
Messages
3,029
Reaction score
97
City, State
West Virginia
Year, Model & Trim Level
1993 2dr
if you still had all your gears just not overdrive and the shifting wasnt smooth you prbly only need a TCC solenoid and 4th grear solenoid. which they prbly did not replace during a trans overhaul. find out what they actually did to your trans.. let us know.
 




atistang

Well-Known Member
Joined
December 17, 2007
Messages
152
Reaction score
0
City, State
Ohio
Year, Model & Trim Level
94 XLT
if you still had all your gears just not overdrive and the shifting wasnt smooth you prbly only need a TCC solenoid and 4th grear solenoid. which they prbly did not replace during a trans overhaul. find out what they actually did to your trans.. let us know.

he said they put a new torque converter, new pump, and new clutches and seals

i loaded the engine in gear again today, if you power brake it, it will go up to 3600rpms and not even try to spin a tire

i filed a credit dispute today so hopefully they can get my money back

i'm gonna check it over real good tomorrow before i go to work and see if it looks like he even removed it, i'm also gonna pull the inspection cover and see if in fact there is a new torque converter or not
 




atistang

Well-Known Member
Joined
December 17, 2007
Messages
152
Reaction score
0
City, State
Ohio
Year, Model & Trim Level
94 XLT
i turned the modulator in and drove it again today, it didn't really get any better. so i'm gonna just wait and see if the bank can get my money back for now
 




Top